TX Profiles lost

DL5RBW
Posts: 46
Joined: Tue Sep 25, 2018 5:37 pm

TX Profiles lost

Postby DL5RBW » Sat Jun 20, 2020 2:46 pm

When I installed "Virtual Audio Cables" and "MMTTY" for RTTY operation this afternoon I noticed that the last TX Profile that I used over the last few weeks has gone. It is not listed in the "Transmit Profile" selection of the main screen anymore. I think that another profile disappeared as well. These two profiles were the last two profiles at the bottom of the selection and I know I have them saved as I switch around between modes frequently and the last profile used always has been restored automatically whenever changing to USB/LSB

Some of the profiles in the 'Transmit Profile' selection are listed in the AppData>Roaming>FlexRadioSystems>PowerSDR folder however not all of them are listed there and unfortunately not the ones that disappeared from the selection list.

Is there any chance to retrieve the file/s or the setting/s and why are some of the TX profiles being saved in this folder but others not although the same procedure has been performed in each case (TX profile saved under the "Profiles" function)?

73 Roger, DL5RBW
User avatar
w-u-2-o
Posts: 2332
Joined: Fri Mar 10, 2017 1:47 pm

Re: TX Profiles lost

Postby w-u-2-o » Sat Jun 20, 2020 4:24 pm

AFAIK there is no way to recover a "lost" profile. Can't see how one could be "lost" without either the database being reset or the profile being explicitly deleted, but stranger things have happened.
DL5RBW
Posts: 46
Joined: Tue Sep 25, 2018 5:37 pm

Re: TX Profiles lost

Postby DL5RBW » Sat Jun 20, 2020 5:05 pm

Is there a way to access the TX profile files that are listed in the 'Transmit Profile' selection on the main screen but cannot be seen in the PowerSDR folder? For instance I see 5 TX profiles in 'Transmit Profile' (next to the MIC slider)

DL5RBW-AM
DL5RBW-FM (VHF)
DL5RBW-JST 245
DL5RBW-HC5
DL5RBW-Sennheiser

but only see the first 3 profiles listed in the PowerSDR folder although I saved all profiles under the Transmit tab in Setup the same way.

The missing profile/s have not been deleted and the database has not been resetted. Just installed MMTTY, VAC and virtual serial port software. Computer has been restarted a couple of times but I don´t see a reason either why the profiles should have get lost.

Funny enough all of a sudden VAC1 is enabled automatically now when I switch to DigiMode and disabled when I leave DigiMode ALTHOUGH the Auto Enable function under the VAC1 tab is NOT checked (see my post in the Digi Mode folder).
User avatar
DH1KLM
Posts: 36
Joined: Fri Dec 29, 2017 10:36 pm
Location: Germany

Re: TX Profiles lost

Postby DH1KLM » Sat Jun 20, 2020 5:46 pm

So all your profiles are still working?
The profiles do not necessarily have to be visible in the program directory or in "\Roaming\FlexRadio Systems" folder.
The TX profiles are always saved in the database. They are only visible in the "\Roaming\FlexRadio Systems" folder after they have been exported.

tx profile export.JPG
tx profile export.JPG (17.35 KiB) Viewed 113 times


Have you tried to export one of those "missing" profiles?

I always export my TX profiles, and copy them from \Roaming\Flexradio Systems to a safe place, just in case the database gets corrupted.
73 de Sigi / DH1KLM

Return to “PowerSDR mRX”