N1MM Radio Connection to Thetis

w3ub
Posts: 12
Joined: Fri Dec 14, 2018 6:32 pm
Location: Lunenburg, NS/Florida

N1MM Radio Connection to Thetis

Postby w3ub » Mon Jul 01, 2019 1:03 pm

I am having problems getting N1MM+ connected to my 7000DLE, running Thetis 2.6.7 for some reason.

My normal logger is HRD, which connects fine. I decided to use the same port, as I am not going to run HRD and N1MM at the same time, CAT2 on port 180, which is paired to port 181 using the Eterlogic VSPE. HRD is set to port 181 and works fine, using a Kenwood TS-480 profile.

I can't get N1MM to connect using port 181. I have tried other port pairs and still can't get it working ...

I am sure I am missing something obvious, but as I have not used N1MM before figured I would ask.

/Doug
w9mdb
Posts: 89
Joined: Sun Apr 09, 2017 5:53 pm

Re: N1MM Radio Connection to Thetis

Postby w9mdb » Mon Jul 01, 2019 1:21 pm

I just tested using the TS-2000 and TS-480 entry from N1MM and they worked just fine.
You need to double-check the serial port parameters in both.
I run 115,200 None,8,1 in Thetis and N1MM shows SO1V 115200,N,8,1,DTR=Always On, RTS=Alyways On, TX=2

de Mike W9MDB
w3ub
Posts: 12
Joined: Fri Dec 14, 2018 6:32 pm
Location: Lunenburg, NS/Florida

Re: N1MM Radio Connection to Thetis

Postby w3ub » Mon Jul 01, 2019 2:21 pm

Yes, I have tried many combinations of port speeds with no joy. Seems like something else is blocking the communication between the two programs?
CAT+.png
CAT+.png (21.24 KiB) Viewed 839 times
N1MM.png
N1MM.png (44.8 KiB) Viewed 839 times
VSPE.png
VSPE.png (11.83 KiB) Viewed 839 times
w9mdb
Posts: 89
Joined: Sun Apr 09, 2017 5:53 pm

Re: N1MM Radio Connection to Thetis

Postby w9mdb » Mon Jul 01, 2019 2:27 pm

I wonder if N1MM or Thetis doesn't like the 3-digit port number. I know that's been a problem in some other software.

Can you try a lower port#? Especially in the 1-9 region ?

Mike
w3ub
Posts: 12
Joined: Fri Dec 14, 2018 6:32 pm
Location: Lunenburg, NS/Florida

Re: N1MM Radio Connection to Thetis

Postby w3ub » Mon Jul 01, 2019 3:52 pm

Yes, good thinking!
I changed the N1MM side to port 6 and it works, looks like N1MM does not like higher port numbers, which is a shame.
Thanks!
Doug
w9mdb
Posts: 89
Joined: Sun Apr 09, 2017 5:53 pm

Re: N1MM Radio Connection to Thetis

Postby w9mdb » Mon Jul 01, 2019 3:55 pm

You should report that problem to N1MM.
There may not be a fix for it but he should be able to put in a warning at least.

Mike
User avatar
w-u-2-o
Posts: 1840
Joined: Fri Mar 10, 2017 1:47 pm

Re: N1MM Radio Connection to Thetis

Postby w-u-2-o » Mon Jul 01, 2019 4:44 pm

N1MM works with two digit port numbers just fine. I'm not surprised it does not work with three digit port numbers. I doubt it would be considered a bug by the author. Besides you, who uses three digit port numbers? ;)
w3ub
Posts: 12
Joined: Fri Dec 14, 2018 6:32 pm
Location: Lunenburg, NS/Florida

Re: N1MM Radio Connection to Thetis

Postby w3ub » Mon Jul 01, 2019 4:58 pm

Yes, it works fine up to 99 ...
Doug

Return to “Digital Mode, Rig Control & Logging Software”