piHPSDR controller discovery not working

NF5F
Posts: 4
Joined: Sun Dec 30, 2018 10:02 pm

piHPSDR controller discovery not working

Postby NF5F » Sun Apr 14, 2019 12:56 am

I got the piHPSDR controller thinking it might be useful for field operations with my 7000DLE. Recently I tested it and found it was no longer able to discover the radio (or any other devices).

A few months ago I upgraded the 7000DLE firmware and moved to Thetis. That all works fine, but when I went back and tested my controller, discovery no longer worked. Thinking I might need to upgrade Raspian or piHPSDR, I got a new micro SD and did a fresh installation of Raspian and version 1.2.3 of piHPSDR. The controller communicates fine with the rest of my network on ethernet and wifi, but it can't seem to find the radio.

Maybe the firmware/software update is a red herring, but discovery has always worked well, so I assume I am missing something simple.

Any suggestions on what I might have missed in the setup process?

Thanks,

Bob / NF5F
User avatar
w-u-2-o
Posts: 1826
Joined: Fri Mar 10, 2017 1:47 pm

Re: piHPSDR controller discovery not working

Postby w-u-2-o » Sun Apr 14, 2019 3:51 pm

Bob,

How are you connecting the pi to the radio hardware? I believe all of the controllers were built with the pi 3B, which only has 10/100 Ethernet. You can't connect it directly to hardware running P2 because P2 only runs at Gigabit speed. You'll have to use a switch, or provision a USB Gigabit interface (make sure there are Raspbian drivers for it), or you can buy a 3B+ and swap out the 3B.

73,

Scott
NF5F
Posts: 4
Joined: Sun Dec 30, 2018 10:02 pm

Re: piHPSDR controller discovery not working

Postby NF5F » Sun Apr 14, 2019 6:08 pm

Spot on, Scott!

I made the bad assumption that all my interfaces were gigabit. Inserting a gigabit switch got them talking again.
Thanks and 73,

Bob / NF5F

Return to “piHPSDR”