Stumped, looking for clues

Posts: 16
Joined: Tue Apr 11, 2017 9:43 pm

Stumped, looking for clues

Postby wb2ems » Sat Mar 10, 2018 8:51 pm

I've been running pihpsdr through a pi unit built originally by K0JTA (his version 1). It's set up with 1.1.3 and runs very nicely except for a bug I can't figure out. Every 60 seconds, the receive or transmit stream is interrupted in a brief stutter that lasts about 1 second. I've described the issue in the receive stutter posting on the forum. As best I can tell, the pi must be doing something once a minute, but I can't tell what that might be. My working theory was that it one of the add on programs that Mike had added like teamviewer. Using the windows software version 4.7 on a variety of machines from a low end pc tablet to a laptop, I can send and receive for hours without a bobble on the same wireless network, so it seems to be specific to this piece of hardware. I've tried running on both the pi's own wireless and also a USB edimax wireless adapter with the same results.

I decided to do a clean build from John's instructions, downloaded a fresh load of Raspbian, got the latest release 1.2.3 and tried that. The first problem was that none of the encoders worked on a fresh build. I tried adjusting the GPIO settings to be the same as what was present on the working version, but it didn't help. I saw some references to hiding a folder or a fresh build fixing things, but I don't know what exactly is to be done. I don't have any of the wiring info, just the old gpio listing that works with the earlier version.

The second problem was that the 60 second dropout seemed to be present with the fresh build as well. :-( And after running a few minutes, there were more interruptions similar to what another user described. I'm wondering if the 1.2.3 version is just too much for the pi to keep up with and maybe it's overheating. Should I be looking at swapping in a tinker board?

I'd like to try to get version 1.2.2 working, but I need to solve the encoder problem - I seem to be missing something about how to move from a copy of 1.1.3 working to the higher level versions. I'm not a linux person, but the instructions seemed fairly straightforward.

If someone can clarify or point me to the right docs on how to get the encoders working with the more recent versions, I can probably chug through trying the various versions to find the one that runs best on this hardware. And if anyone has any clues on what is breaking up the stream every 60 seconds that I can chase down, that would be very helpful. It's really a great project and works 95% for me, I just need to fix that last couple of percent to make it usable.

Thanks and 73 from Kevin, WB2EMS

Return to “piHPSDR”