Fatal Error After Database Import

ron4094
Posts: 22
Joined: Sun Nov 24, 2019 1:16 am

Fatal Error After Database Import

Postby ron4094 » Wed Jun 03, 2020 6:47 pm

Today I installed the latest versions of Thetis and Protocol V2 into my Anan 7000dle mk2 with no issues. The radio appeared to be working properly. I then imported my saved database from Open HPSDR and then got a Fatal Error message. At this point I deleted Thetis and reinstalled it and still got the message. I then restored my computer to a date prior to installing Thetis, reinstalled the software along with Net framework 4.8.0 and still got the message. I do want to mention that after each reinstall of Thetis, the computer did not go through the long optimization routine that was performed with my initial installation of Thetis. The error notice is in the attachment. Any help would be greatly appreciated.

Thanks,
Ron
WB2RON
Attachments
Untitled.jpg
Untitled.jpg (414.31 KiB) Viewed 1280 times
User avatar
Tony EI7BMB
Posts: 393
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Fatal Error After Database Import

Postby Tony EI7BMB » Wed Jun 03, 2020 7:09 pm

Got this myself recently . I deleted the database (database.xml )in the thetis folder under App data then reinstalled Thetis using the last public release and then re imported my backup database . I also copied in Ramdors files as I'm not 100% sure they are incorporated into the latest public release. Hope this helps
ron4094
Posts: 22
Joined: Sun Nov 24, 2019 1:16 am

Re: Fatal Error After Database Import

Postby ron4094 » Wed Jun 03, 2020 7:59 pm

Since this was a new install, the database that was in the Thetis folder is the default database, not the one that I imported but I still get the same fatal error message. I suspect that it may work if I do a clean install where the computer goes through the optimization routine but I don't know how to do this. If nothing else works I can reinstall the operating system but that is a major project. My other option is to forget about Thetis and just go back to PowerSDR.

Ron
WB2RON
oe3ide
Posts: 19
Joined: Tue May 05, 2020 8:36 am
Contact:

Re: Fatal Error After Database Import

Postby oe3ide » Wed Jun 03, 2020 8:06 pm

Just delete (or rename) "wdspWisdom00" in users\<youruser>\appdata\roaming\openhpsdr\thetis.
After that, start Thetis and the FFT optimization process starts.
ron4094
Posts: 22
Joined: Sun Nov 24, 2019 1:16 am

Re: Fatal Error After Database Import

Postby ron4094 » Wed Jun 03, 2020 8:13 pm

I just noticed that there is an archive database folder in the Thetis directory. I replaced database.xml with this file and I no longer get the fatal error. I will now check out the radio and see if there are any other issues.

Thanks,
Ron
WB2RON
K1LSB
Posts: 86
Joined: Wed Feb 05, 2020 5:25 pm

Re: Fatal Error After Database Import

Postby K1LSB » Thu Jun 04, 2020 2:49 am

Whenever i get that error after Importing a Database I just exit the Thetis session, go into the Thetis database folder, delete the database.xml file, copy and paste the database I tried unsuccessfully to import, then rename the pasted database file as database.xml and re-open the Thetis session. Works every time.
ron4094
Posts: 22
Joined: Sun Nov 24, 2019 1:16 am

Re: Fatal Error After Database Import

Postby ron4094 » Thu Jun 04, 2020 2:33 pm

Thanks everyone. Thetis is now operating properly after correcting the imported database. I have now gone through a complete calibration of transmit power levels, receive calibration level (-73dbm) and on -the-air checks and have found no issues at this time. I have also imported my transmit profiles from Open HPSDR and they are all working properly.

Ron
WB2RON

Return to “Thetis”