Thetis 2.8.11 Released!

vu2mb
Posts: 40
Joined: Thu Nov 21, 2019 5:30 pm

Re: Thetis 2.8.7 Released!

Postby vu2mb » Fri Oct 09, 2020 3:13 pm

Dear Doug,

Amazing work. New Thetis is simply amazing. Now I can use both my radios with the same software without switching. One of my radio is programmed for Protocol 1. Thank you very much for this much awaited release.
We are so grateful for your work. Thanks again.
Bhanu
VU2MB
DL8LAQ
Posts: 99
Joined: Sun Apr 09, 2017 3:28 pm

Re: Thetis 2.8.7 Released!

Postby DL8LAQ » Fri Oct 09, 2020 6:45 pm

Hi Doug and helper,

thank you for the new version/s :-)
73, Norbert - DL8LAQ - ANAN-7000DLE
User avatar
n4lq
Posts: 27
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Thetis 2.8.6 Released!

Postby n4lq » Sat Oct 10, 2020 12:19 am

W3MMR wrote:
n4lq wrote:Thanks for the update!

64 bit Thetis reduced CPU% usage from 3% to 1% (Thetis only usage) at 192k sampling rate. Impressive.
System usage peaks out at 4% with 11 tabs of Chrome, Logger32, Telnet and VSPE running.

Observation:
Switching between RX1 sample rates was seamless with previous version 32bit. Now when switching, audio is lost and power off/on brings it back with 64bit. Not really a problem.



But what PC are you using...


CPU is Intel I9-9900K
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
dj1yr
Posts: 28
Joined: Mon Apr 10, 2017 2:32 am

Re: Thetis 2.8.7 Released!

Postby dj1yr » Sat Oct 10, 2020 5:25 am

Nice to read that it continues.

Where can I download the current version, the link in the start post does not lead to the target.

edit:
thanks, found!
laserbill
Posts: 21
Joined: Thu Apr 05, 2018 8:43 am
Location: West Yorkshire

Re: Thetis 2.8.7 Released!

Postby laserbill » Sat Oct 10, 2020 5:45 am

Happy to report all working fine on my 100D Grey face unit.
The easy choice would be to quietly drop support for the older hardware..... But not with this team!
Well done all involved in this project, It just shows when you have a dedicated team of committed
people what can be achieved.
Best 73
Bill
Dave30019
Posts: 20
Joined: Thu Oct 31, 2019 10:54 am

Re: Thetis 2.8.7 Released!

Postby Dave30019 » Sat Oct 10, 2020 11:01 am

Can I import my latest database from my 2.7(a3) version. Or do I have to reconfigure from scratch with the 64 bit version?

I successfully installed 2.8.7 so I want to proceed cautiously.

Dave
k4em

EDIT: I found some screen shots I had saved on a USB stick, so I just re-entered my settings and it seems to be OK. I'll do a more thorough test this weekend on SSB, CW & FT8.
Last edited by Dave30019 on Sat Oct 10, 2020 12:37 pm, edited 1 time in total.
NC3Z
Posts: 248
Joined: Sun Oct 29, 2017 8:57 pm
Location: Merritt, NC

Re: Thetis 2.8.7 Released!

Postby NC3Z » Sat Oct 10, 2020 11:20 am

Dave30019 wrote:Can I import my latest database from my 2.7(a3) version.


Dave, it will do a conversion for you. Of course keep a backup of the 2.7.0 db (I just keep the whole folders to be safe for a bit).

Once the 64 bit version gets fixed and I migrate to it I will take the time to do a whole new database build from scratch just for good measures.
Gary NC3Z
User avatar
w-u-2-o
Posts: 2599
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.8.7 Released!

Postby w-u-2-o » Sat Oct 10, 2020 11:40 am

Gary,

I had absolutely no problem bringing my database, and midi, and memory files over to the x64 version. Just copy/paste them from the 32 bit settings folder to the 64 bit settings folder. Easy day.

73,

Scott
NC3Z
Posts: 248
Joined: Sun Oct 29, 2017 8:57 pm
Location: Merritt, NC

Re: Thetis 2.8.7 Released!

Postby NC3Z » Sat Oct 10, 2020 11:55 am

So midi is fixed now in the 64 bit version?
Gary NC3Z
User avatar
w-u-2-o
Posts: 2599
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.8.7 Released!

Postby w-u-2-o » Sat Oct 10, 2020 12:03 pm

Almost!
NC3Z
Posts: 248
Joined: Sun Oct 29, 2017 8:57 pm
Location: Merritt, NC

Re: Thetis 2.8.7 Released!

Postby NC3Z » Sat Oct 10, 2020 12:07 pm

OK, when you said you copied the Midi files over and had no issue I assumed it was fixed. Yes I am aware you can copy over but I was replying to a question about migrating from 2.7.0, which will do a db conversion.
Gary NC3Z
User avatar
w-u-2-o
Posts: 2599
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.8.7 Released!

Postby w-u-2-o » Sat Oct 10, 2020 12:17 pm

NC3Z wrote:Once the 64 bit version gets fixed and I migrate to it I will take the time to do a whole new database build from scratch just for good measures.


Gary--to clarify, while your above quote represents an abundance of caution, what I was trying to say was that it was probably unnecessary. Just copying the 32 bit database.xml file over should be more than adequate. However, if it makes you feel better, rebuilding the database from bare metal is certainly a very safe way of proceeding.
User avatar
DK1WP
Posts: 8
Joined: Thu Apr 25, 2019 4:12 pm
Location: Germany
Contact:

Re: Thetis 2.8.7 Released!

Postby DK1WP » Sat Oct 10, 2020 1:10 pm

Red Pitaya users also benefit from this and can now use all Thetis functionalities.
Great work!

Marcus - dk1wp.de
73 Marcus

ANAN 200D - Firmware 1.9_pre4 - Thetis 2.8.11 - LinHPSDR
User avatar
w-u-2-o
Posts: 2599
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.8.7 Released!

Postby w-u-2-o » Sat Oct 10, 2020 2:13 pm

For those of you who do not wish to wait for 2.8.8 (which is pending the antenna selection fixes) to get MIDI working on the 64 bit build, attached to this post is a .rar archive containing the two files you need to replace in C:\Program Files\OpenHPSDR\Thetis

With those two files replaced, the 64 bit version should function correctly with MIDI devices.

No other changes should be necessary.
Don't use these files to update your 32 bit installation.
You should probably make backups of your 64 bit installation before hanging it out over the bleeding edge like this ;)

73,

Scott
Attachments
Thetis_2.8.7_9Oct_patch_64_bit_for_MIDI.rar
(3.97 MiB) Downloaded 106 times
User avatar
DK1WP
Posts: 8
Joined: Thu Apr 25, 2019 4:12 pm
Location: Germany
Contact:

Re: Thetis 2.8.7 Released!

Postby DK1WP » Sat Oct 10, 2020 2:30 pm

Midi now works without problems again.
Many thanks to Scott for the update.
73 Marcus

ANAN 200D - Firmware 1.9_pre4 - Thetis 2.8.11 - LinHPSDR
User avatar
Tony EI7BMB
Posts: 382
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.8.7 Released!

Postby Tony EI7BMB » Sat Oct 10, 2020 3:20 pm

Thanks Scott , will try this tomorrow
Edit: all working, just had to add the files from Scott and load the midi mapping from 32 bit version.
Last edited by Tony EI7BMB on Sun Oct 11, 2020 11:40 am, edited 1 time in total.
casey1elqueo
Posts: 11
Joined: Thu Jul 23, 2020 11:45 pm

Re: Thetis 2.8.7 Released!

Postby casey1elqueo » Sun Oct 11, 2020 3:01 am

w-u-2-o wrote:For those of you who do not wish to wait for 2.8.8 (which is pending the antenna selection fixes) to get MIDI working on the 64 bit build, attached to this post is a .rar archive containing the two files you need to replace in C:\Program Files\OpenHPSDR\Thetis

With those two files replaced, the 64 bit version should function correctly with MIDI devices.

No other changes should be necessary.
Don't use these files to update your 32 bit installation.
You should probably make backups of your 64 bit installation before hanging it out over the bleeding edge like this ;)

73,

Scott


Verified it works. Many thanks! (using DJ Control Compact which just came in today... very cool)
User avatar
W3MMR
Posts: 81
Joined: Thu Jul 11, 2019 8:36 am
Location: Chester, PA
Contact:

Re: Thetis 2.8.6 Released!

Postby W3MMR » Sun Oct 11, 2020 9:46 am

n4lq wrote:Thanks for the update!

64 bit Thetis reduced CPU% usage from 3% to 1% (Thetis only usage) at 192k sampling rate. Impressive.
System usage peaks out at 4% with 11 tabs of Chrome, Logger32, Telnet and VSPE running.

Observation:
Switching between RX1 sample rates was seamless with previous version 32bit. Now when switching, audio is lost and power off/on brings it back with 64bit. Not really a problem.


What PC are you using? Also. Thetis settings have a TON to do with CPU%. The CPU% you are getting sounds like when you do a fresh install, all settings are factory, and the window size is as small as you can make it. With MY settings, and you can see my PC in my signature, 2013x1251 resolution, 125fps, directX, Anti_Aliasing, etc etc etc. You get my point lol. Im seeing a 3-4% decrease in CPU% with the 64 bit version.

Perry
Studio "A" - Anan 200D, P2 1.9, Thetis 2.6.9c3, Dell XPS 8700 i7-4770k, Samsung EVO 860 SSD, Nvidia GeForce GTX1050ti, 16GB RAM, Shure SM7B, AL80BX
Studio "B" - Heath-Kit DX100, D-104, National NC-303, Hammarlund HQ-140-X
User avatar
w-u-2-o
Posts: 2599
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.8.8 Released!

Postby w-u-2-o » Sun Oct 11, 2020 2:56 pm

2.8.8 is now released. See the first post in this topic.
User avatar
W1RHS
Posts: 7
Joined: Thu Feb 13, 2020 3:29 am
Location: Cape Cod, USA
Contact:

Re: Thetis 2.8.8 Released!

Postby W1RHS » Sun Oct 11, 2020 3:11 pm

Thank you for 2.8.8. Installed perfectly!
Rick, W1RHS
7000DLE MKII
ea3aqr
Posts: 85
Joined: Mon Mar 04, 2019 10:50 pm
Location: BCN

Re: Thetis 2.8.8 Released!

Postby ea3aqr » Sun Oct 11, 2020 5:28 pm

V2.8.8 RX antenna selection control on console not showing changes when out of some bands.

Please test it on 11m band, the antenna is switching but no change shown on console.
User avatar
W1AEX
Posts: 320
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: Thetis 2.8.8 Released!

Postby W1AEX » Sun Oct 11, 2020 6:53 pm

I installed the 32-bit and 64-bit versions and then imported my current database into each version. It all went in smoothly and both versions are working beautifully with my P1 and also my P2 firmware. Nice job with this whole project Doug and Warren and thank you Scott for all the documentation.

I cannot imagine that anyone who is still running PSDR v3.4.9 would stay there once they see the effect of Direct X on the rendering of the pandadapter and waterfall. Anyone who is hesitant should know that they can stay on P1 if they don't want to flash to P2 and their old PSDR installation will safely co-exist with both versions (32 and 64 bit) of Thetis so no worries about losing what they already have.

73, Rob W1AEX
"One thing I am certain of is that there is too much certainty in the world."
laurencebarker
Posts: 41
Joined: Mon Nov 11, 2019 7:39 pm

Re: Thetis 2.8.8 Released!

Postby laurencebarker » Sun Oct 11, 2020 7:34 pm

EA3AQR: I suspect my code isn't noticing antenna changes in between the amateur bands. OK, I can look at that.

Can you tell me what you did - what antennas you have set for which bands, and where you tuned from and to that caused the antenna change that wasn't displayed please?
Laurence Barker G8NJJ
K1LSB
Posts: 60
Joined: Wed Feb 05, 2020 5:25 pm

Re: Thetis 2.8.8 Released!

Postby K1LSB » Sun Oct 11, 2020 7:50 pm

I posted this in a different thread but I suspect I should have posted it here...

VAC1 is stable on v2.8.8 but I'm getting crazy runaway Underflows on VAC2, nothing I change on buffers, sample rates or Force even slows it down.

This wasn't happening before, including in yesterday's v2.8.7, so I suspect something has changed in v2.8.8.

I need VAC2 for digital modes so I'll probably revert back to v2.8.7.

Mark

Capture.PNG
Capture.PNG (175.31 KiB) Viewed 1871 times
User avatar
W9BHI
Posts: 34
Joined: Wed Apr 17, 2019 3:30 pm
Location: Serena Il.

Re: Thetis 2.8.8 Released!

Postby W9BHI » Sun Oct 11, 2020 8:21 pm

Did the band stack lock get fixed?
ea3aqr
Posts: 85
Joined: Mon Mar 04, 2019 10:50 pm
Location: BCN

Re: Thetis 2.8.8 Released!

Postby ea3aqr » Sun Oct 11, 2020 9:20 pm

laurencebarker wrote:EA3AQR: I suspect my code isn't noticing antenna changes in between the amateur bands. OK, I can look at that.

Can you tell me what you did - what antennas you have set for which bands, and where you tuned from and to that caused the antenna change that wasn't displayed please?


Here you can see the problem:

Bryan W4WMT
Posts: 111
Joined: Sun Apr 09, 2017 10:12 pm

Re: Thetis 2.8.8 Released!

Postby Bryan W4WMT » Sun Oct 11, 2020 11:41 pm

K1LSB wrote:I posted this in a different thread but I suspect I should have posted it here...

VAC1 is stable on v2.8.8 but I'm getting crazy runaway Underflows on VAC2, nothing I change on buffers, sample rates or Force even slows it down.

This wasn't happening before, including in yesterday's v2.8.7, so I suspect something has changed in v2.8.8.

I need VAC2 for digital modes so I'll probably revert back to v2.8.7.

Mark



Mark, see my reply in the orig thread.
K1LSB
Posts: 60
Joined: Wed Feb 05, 2020 5:25 pm

Re: Thetis 2.8.8 Released!

Postby K1LSB » Mon Oct 12, 2020 12:47 am

Bryan,

Thank you sir, you nailed it! The RX2 receiver was not running. I turned it on and VAC2 is behaving correctly.

73,
Mark
va7qi
Posts: 21
Joined: Mon Apr 10, 2017 4:22 am
Location: Quadra Island, BC

Re: Thetis 2.8.8 Released!

Postby va7qi » Mon Oct 12, 2020 5:06 am

A bug in 2.8.6?

Doug, thanks for the new Thetis release. The new Memory form is very interesting.

Now, it could be my ageing brain, but I am not able to get any power out in SSB. No audio when I turn Monitor on, either. The microphone settings are the same as for 2.7.0.

Any suggestions?

BTW, I made several QSOs on FT-8 today with no problems, but I did notice that the power output was much higher than I had with the old version.

73 de va7qi, ....Erik.
va7qi
Posts: 21
Joined: Mon Apr 10, 2017 4:22 am
Location: Quadra Island, BC

Re: Thetis 2.8.8 Released!

Postby va7qi » Mon Oct 12, 2020 5:30 am

Sorry, that is 2.8.7.

Also, the hardware here is the 3000DLE MkII. Also tested on an Anan-10 with Protocol 1, but RX only.

73 de va7qi, ....Erik.

Return to “Thetis”