Thetis 2.7.0

User avatar
DH1KLM
Posts: 43
Joined: Fri Dec 29, 2017 10:36 pm
Location: Germany

Thetis 2.7.0

Postby DH1KLM » Thu Feb 06, 2020 1:22 pm

FYI, Thetis 2.7.0 sources out now.
https://github.com/w5wc/Thetis-2.7.0
Compiled it yesterday and did a short test.
Look's OK so far, but have to play around a bit more.
73 de Sigi / DH1KLM
DL8LAQ
Posts: 96
Joined: Sun Apr 09, 2017 3:28 pm

Re: Thetis 2.7.0

Postby DL8LAQ » Fri Feb 07, 2020 6:50 pm

Hi Sigi,

I would like to test your compiled files. I don't know how to compile the sources on my windows pc, maybe we can talk by phone oder teamspeak.
73, Norbert - DL8LAQ - ANAN-7000DLE
DL8LAQ
Posts: 96
Joined: Sun Apr 09, 2017 3:28 pm

Re: Thetis 2.7.0

Postby DL8LAQ » Sun Feb 09, 2020 12:46 pm

Hi Sigi,

I did install Visual Studio 2019 yesterday and it seems to works. Just tested the self-compiled 2.6.9 and 2.7.0.

I just tried to TX with my 2-m-band-xvtr, but failed due to not working ptt control. The xvtr ptt is connected to the rear panel rca jack on my ANAN-7000.

I switched back to 2.6.9c3 by Richie.
73, Norbert - DL8LAQ - ANAN-7000DLE
4z1ao
Posts: 6
Joined: Wed Apr 11, 2018 10:05 am

Re: Thetis 2.7.0

Postby 4z1ao » Sun Feb 09, 2020 12:56 pm

Compiled it too.
Played a bit with the Release version. Looks good so far.

73 Isaac 4Z1AO
DL8LAQ
Posts: 96
Joined: Sun Apr 09, 2017 3:28 pm

Re: Thetis 2.7.0

Postby DL8LAQ » Sun Feb 09, 2020 1:02 pm

4z1ao wrote:Compiled it too.
Played a bit with the Release version. Looks good so far.


Hi Isaac,

can you please try to setup for a 2-m-xvtr and check the ptt output on your radio?
73, Norbert - DL8LAQ - ANAN-7000DLE
jeffreydoran
Posts: 69
Joined: Sun Oct 29, 2017 9:39 pm

Re: Thetis 2.7.0

Postby jeffreydoran » Sun Feb 09, 2020 6:53 pm

Are there any release notes for 2.7.0? Can anyone summarize the difference between this version and 2.6.9?

Jeff NJ2US
User avatar
DH1KLM
Posts: 43
Joined: Fri Dec 29, 2017 10:36 pm
Location: Germany

Re: Thetis 2.7.0

Postby DH1KLM » Mon Feb 10, 2020 11:42 am

DL8LAQ wrote:I switched back to 2.6.9c3 by Richie.


I recommend to ask Richie about the changes.
Maybe he could point you in the right direction.
too bad that Richies source files are not visible, otherwise you could search for the differences in the XVTR control yourself. Today I try to connect the Alex interface and report back what the XVTR PTT does for me.
73 de Sigi / DH1KLM
User avatar
w-u-2-o
Posts: 2430
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.7.0

Postby w-u-2-o » Mon Feb 10, 2020 11:55 am

AFAIK, Richie is taking a break from coding. That means any changes are most likely from Doug and Laurence and associated with the Andromeda project.
Bryan W4WMT
Posts: 104
Joined: Sun Apr 09, 2017 10:12 pm

Re: Thetis 2.7.0

Postby Bryan W4WMT » Mon Feb 10, 2020 12:02 pm

jeffreydoran wrote:Are there any release notes for 2.7.0? Can anyone summarize the difference between this version and 2.6.9?

Jeff NJ2US


It's kind of difficult to know, because 2.7.0 has forked off into a completely new git repository, and so we can't do a simple diff to see all the changes.

I just did a file compare in WinMerge between 2.6.9 and 2.7.0 in W5WC's GitHub. All the low level stuff is exactly the same, ie zero changes in WDSP and The ChannelMaster. Many changes were done in the Console and Setup classes. The Console is a scary and confusing place that dates all the way back to the SDR-1000 days at Flex, so it's hard for me to understand what all the changed were. My sense, after scanning quickly through all the changes, is there was a lot of code cleanup, housekeeping, and some modest refactoring in Console and Setup.

73
4z1ao
Posts: 6
Joined: Wed Apr 11, 2018 10:05 am

Re: Thetis 2.7.0

Postby 4z1ao » Mon Feb 10, 2020 4:53 pm

DL8LAQ wrote: Hi Isaac,

can you please try to setup for a 2-m-xvtr and check the ptt output on your radio?


I'll try and let you know.
DL8LAQ
Posts: 96
Joined: Sun Apr 09, 2017 3:28 pm

Re: Thetis 2.7.0

Postby DL8LAQ » Mon Feb 10, 2020 5:25 pm

4z1ao wrote:
DL8LAQ wrote:can you please try to setup for a 2-m-xvtr and check the ptt output on your radio?


I'll try and let you know.


I think it's ok now with f/w Orion_MkII_NP_v2.0b! Now I can use the self-compiled 2.7.0. The footswitch is working in CW and the PTT out is active, that means the PA PTT or the XVTR is controlled by footswitch! That is what I missed for long time!!!!

By the way, the PTT by space bar seems to not work now - yes, I enabled MOX by space bar - but that is no problem since the footswitch is available in any mode.

Thank you guys for fixing this :-)
73, Norbert - DL8LAQ - ANAN-7000DLE
User avatar
DH1KLM
Posts: 43
Joined: Fri Dec 29, 2017 10:36 pm
Location: Germany

Re: Thetis 2.7.0

Postby DH1KLM » Mon Feb 10, 2020 7:34 pm

Hello Norbert,
good to hear it is working now.
For spacebar PTT have a look at the pic.

1.PNG
1.PNG (29.29 KiB) Viewed 8333 times

2.PNG
2.PNG (15.23 KiB) Viewed 8333 times
73 de Sigi / DH1KLM
DL8LAQ
Posts: 96
Joined: Sun Apr 09, 2017 3:28 pm

Re: Thetis 2.7.0

Postby DL8LAQ » Wed Feb 12, 2020 6:05 pm

DH1KLM wrote:Hello Norbert,
good to hear it is working now.
For spacebar PTT have a look at the pic.


Hi Sigi,

that is the solution. Thank you! :-) Enable shortcuts was not ticked.
73, Norbert - DL8LAQ - ANAN-7000DLE
GW0DQW
Posts: 32
Joined: Sun Apr 09, 2017 4:21 pm
Location: Nr Cardiff
Contact:

Re: Thetis 2.7.0

Postby GW0DQW » Sat Feb 15, 2020 7:10 pm

DH1KLM wrote:Hello Norbert,
good to hear it is working now.
For spacebar PTT have a look at the pic.

1.PNG
2.PNG



Space bar working Norbert , thank you very much .
Chris
GW0DQW :)
dj1yr
Posts: 26
Joined: Mon Apr 10, 2017 2:32 am

Re: Thetis 2.7.0

Postby dj1yr » Sun Feb 16, 2020 1:29 pm

have compiled thetis 2.7.0, if you want to test, please ...

https://www.file-upload.net/download-13 ... 0.zip.html
User avatar
Tony EI7BMB
Posts: 373
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.7.0

Postby Tony EI7BMB » Sun Feb 16, 2020 2:01 pm

Thanks but could not get this working, radio would not switch on . back to 2.6.9

dj1yr wrote:have compiled thetis 2.7.0, if you want to test, please ...

https://www.file-upload.net/download-13 ... 0.zip.html
dj1yr
Posts: 26
Joined: Mon Apr 10, 2017 2:32 am

Re: Thetis 2.7.0

Postby dj1yr » Sun Feb 16, 2020 3:48 pm

Did you choose the right radio?
User avatar
Tony EI7BMB
Posts: 373
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.7.0

Postby Tony EI7BMB » Sun Feb 16, 2020 5:02 pm

I presume so as it updated existing database.
User avatar
DH1KLM
Posts: 43
Joined: Fri Dec 29, 2017 10:36 pm
Location: Germany

Re: Thetis 2.7.0

Postby DH1KLM » Sun Feb 16, 2020 8:02 pm

I had the same experience when updating an existing database.
Obviously the radio model is not updated in Setup> General> H / W Select.
I noticed this behavior even after importing an older database. The radio was then set to HPSDR instead of Hermes.
But I think that most of the other settings were adopted, at least I could not find any other differences.
73 de Sigi / DH1KLM
dj1yr
Posts: 26
Joined: Mon Apr 10, 2017 2:32 am

Re: Thetis 2.7.0

Postby dj1yr » Sun Feb 16, 2020 11:31 pm

It was the same with me
User avatar
Tony EI7BMB
Posts: 373
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.7.0

Postby Tony EI7BMB » Mon Feb 17, 2020 9:45 am

Thanks guys you were right, the correct radio was not selected . Seems to be working on RX so far.
User avatar
Tony EI7BMB
Posts: 373
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.7.0

Postby Tony EI7BMB » Fri Feb 21, 2020 9:15 am

2.7.0 does not seem to remember the last TX mode on startup , anyone else seeing this ?
User avatar
rbduck
Posts: 85
Joined: Tue Dec 03, 2019 1:49 pm

Re: Thetis 2.7.0

Postby rbduck » Fri Feb 21, 2020 3:54 pm

I'm having no issues with Thetis 2.7.0 remembering the TX mode on startup
73
Ruben
NB4R

"Beware the typos and edits. My brain can't keep up with my fingers."
User avatar
DK1WP
Posts: 5
Joined: Thu Apr 25, 2019 4:12 pm
Location: Germany
Contact:

Re: Thetis 2.7.0

Postby DK1WP » Fri Feb 21, 2020 6:02 pm

After the first start of 2.7.0 under General -> H/W Select the correct transceiver was not taken over.

Also the audio profile (Transmit Filter as well as CFC settings) had to be adjusted.

All other settings like PA Settings, Display, CAT were taken over from 2.6.9.
Last edited by DK1WP on Fri Feb 21, 2020 6:27 pm, edited 1 time in total.
73 Marcus

ANAN 200D - Firmware 1.9_pre4 - Thetis 2.7.0. a3 - LinHPSDR
User avatar
Tony EI7BMB
Posts: 373
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.7.0

Postby Tony EI7BMB » Fri Feb 21, 2020 6:15 pm

Yes the database upgrade did not capture the mode so has to be set correctly and saved again under the correct TX profile.

Edit: Tested again and the program resets every time to LSB when profile was set to DIGU
User avatar
rbduck
Posts: 85
Joined: Tue Dec 03, 2019 1:49 pm

Re: Thetis 2.7.0

Postby rbduck » Fri Feb 21, 2020 11:47 pm

In this case yes. The first time I started 2.7.0 I had to go through and correct many settings that did not come over from 2.6.9. After that I had no issues.
73
Ruben
NB4R

"Beware the typos and edits. My brain can't keep up with my fingers."
User avatar
Tony EI7BMB
Posts: 373
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis 2.7.0

Postby Tony EI7BMB » Sat Feb 22, 2020 12:03 pm

Yep definitely an issue here , no matter what I do it goes back to LSB on startup unless I'm missing something obvious. Not a big deal either way
dalemitchell
Posts: 3
Joined: Mon Feb 24, 2020 12:43 pm

Re: Thetis 2.7.0

Postby dalemitchell » Mon Feb 24, 2020 9:21 pm

Where can i download Thetis 2.7.0 $
dj1yr
Posts: 26
Joined: Mon Apr 10, 2017 2:32 am

Re: Thetis 2.7.0

Postby dj1yr » Tue Feb 25, 2020 1:19 am

dj1yr wrote:have compiled thetis 2.7.0, if you want to test, please ...

https://www.file-upload.net/download-13 ... 0.zip.html
dalemitchell
Posts: 3
Joined: Mon Feb 24, 2020 12:43 pm

Re: Thetis 2.7.0

Postby dalemitchell » Tue Feb 25, 2020 12:02 pm

Thanks
Dale

Return to “Thetis”