2.6.9

User avatar
w2ner
Posts: 68
Joined: Wed Sep 11, 2019 12:14 am

Re: 2.6.9

Postby w2ner » Sat Nov 16, 2019 1:18 am

ramdor wrote:UPDATE

Hi all,

Please try : https://www.dropbox.com/s/kafb2ln3dvbgx ... 6.zip?dl=0

There are quite a number of changes 'under the hood' in regards to display. Also please keep an eye out for the errorlog.txt file.

Note: use all the files in the zip

After the weekend testing, source for a6 will go off to Doug.

Cheers, Richie.

(11/3/10) a6
  • add: when using a single RX and when in panafall, the splitter between panadaptor and waterfall can be dragged up and down. Right click to recenter
  • fix: untrapped exception on shut down caused by thread time outs in power off button not waiting long enough (display_volts_amps_thead)
  • change: thread time out for multimeter_thread(s) in power off button state now based on meter delay
  • add: ErrorLog.txt created if any untrapped .NET or DirectX issues (\Users\<user>\AppData\Roaming\OpenHPSDR\Thetis\ErrorLog.txt)
  • fix: rx2 waterfall bitmap resized correctly, this would only be noticeable if you switched from panafall to waterfall on rx2
  • change: grid scale numbers flip side away from passband filter for USB/LSB/DIGU/DIGL/CWU/CWL



GREAT WORK Richie!!!
NC3Z
Posts: 215
Joined: Sun Oct 29, 2017 8:57 pm
Location: Merritt, NC

Re: 2.6.9

Postby NC3Z » Sat Nov 16, 2019 1:33 am

Ritchie, just asking, will the slider be ported eventually to RX2 also?
Gary NC3Z
Bryan W4WMT
Posts: 96
Joined: Sun Apr 09, 2017 10:12 pm

Re: 2.6.9

Postby Bryan W4WMT » Sat Nov 16, 2019 1:41 am

ramdor wrote:Implemented in both, but existing waterfall bitmap is lost on mouse release. DX version copies existing waterfall over to new bitmap if same width. There is more work to do on all of that stuff really, but it is workable.

edit: i am tempted to pull gdi+ because everything is double the work.

edit2: there are some issues with overlay filter size heights in gdi+, i will sort it before it goes off to Doug. Probably forgot to make the changes to the gdi+ side of those :roll:

Richie.


Hi Richie,

I certainly appreciate that maintaining GDI+ support is double the work!
I am seeing some thread blocking of the DDC streams and the PortAudio stream when in DirectX mode that I don't see in GDI+ mode. Hopefully I can get to the bottom of this before you "pull the plug" on GDI+ :roll:

73
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 1:41 am

NC3Z wrote:Ritchie, just asking, will the slider be ported eventually to RX2 also?


only the display system only knows about a single receiver, there are too many code paths to do it nicely at the moment. It will be in the future when the drag/docking system is implemented.

Richie.
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 1:42 am

see post below
Last edited by ramdor on Sat Nov 16, 2019 1:55 am, edited 1 time in total.
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 1:51 am

Just to note, F/G/H lines are drawn always in GDI mode even in when in mox state. This is now fixed, will be included in distrib after weekend testing. F/G/H lines in DirectX are ok.

EDIT: zips updated with this fixed : https://www.dropbox.com/s/5t37sk4zdf3zq ... 2.zip?dl=0

Richie.
User avatar
w-u-2-o
Posts: 2139
Joined: Fri Mar 10, 2017 1:47 pm

Re: 2.6.9

Postby w-u-2-o » Sat Nov 16, 2019 2:09 am

Great work as always, Richie!

Not going to make it over there to buy you a pint until after the new year :cry:

Time to bury GDI! I'm sure there is some sad corner case out there somewhere, but, seriously, who has a machine that can't run DirectX? It's 2019, for cryin' out loud! I mean, we are now older than Blade Runner!

73 :)

Scott
NC3Z
Posts: 215
Joined: Sun Oct 29, 2017 8:57 pm
Location: Merritt, NC

Re: 2.6.9

Postby NC3Z » Sat Nov 16, 2019 2:12 am

What about my Win XP Pentium 3 box?
Gary NC3Z
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 2:13 am

Bryan W4WMT wrote:I am seeing some thread blocking of the DDC streams and the PortAudio stream when in DirectX mode that I don't see in GDI+ mode. Hopefully I can get to the bottom of this before you "pull the plug" on GDI+ :roll:
73


That is interesting Bryan. In DirectX mode and not in GDI+ mode?

Richie.
User avatar
w-u-2-o
Posts: 2139
Joined: Fri Mar 10, 2017 1:47 pm

Re: 2.6.9

Postby w-u-2-o » Sat Nov 16, 2019 2:14 am

Gary,

Don't you have a door that blows open or closed when the wind blows? Sure you do. Clearly it needs a doorstop... ;)

73!

Scott
jeffreydoran
Posts: 69
Joined: Sun Oct 29, 2017 9:39 pm

Re: 2.6.9

Postby jeffreydoran » Sat Nov 16, 2019 2:40 am

7000DLE 2.6.9 a6_2
Connected to a dedicated NIC on its own subnet
Submitted by NJ2US

DCC0
s0=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 1 -2 1 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:12:47:681
s1=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 1 -2 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:924
s2=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 1 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s3=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s4=1 0 0 0 0 0 1 -2 2 -2 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s5=1 0 0 0 0 0 1 -2 2 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s6=1 0 0 0 0 0 1 -2 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s7=1 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s8=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:922
s9=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:922
s10=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 0 11/15 21:10:19:922
s11=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 2 0 0 0 11/15 21:10:19:922
s12=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 -2 2 0 0 0 11/15 21:10:19:922
s13=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 -2 2 0 0 0 11/15 21:10:19:922
s14=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s15=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s16=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s17=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s18=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 0 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:920
s19=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 0 0 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:920

DCC0
s0=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 1 -2 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:924
s1=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 1 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s2=1 0 0 0 0 0 1 -2 2 -2 1 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s3=1 0 0 0 0 0 1 -2 2 -2 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s4=1 0 0 0 0 0 1 -2 2 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s5=1 0 0 0 0 0 1 -2 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s6=1 0 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:923
s7=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:922
s8=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 -2 11/15 21:10:19:922
s9=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 0 0 1 0 11/15 21:10:19:922
s10=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 1 2 0 0 0 11/15 21:10:19:922
s11=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 -2 2 0 0 0 11/15 21:10:19:922
s12=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 1 -2 -2 2 0 0 0 11/15 21:10:19:922
s13=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s14=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s15=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s16=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 1 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:921
s17=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 -2 0 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:920
s18=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 1 0 0 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:920
s19=1 -2 1 0 1 -2 1 0 0 0 0 0 0 0 0 0 0 1 -2 1 0 0 0 0 0 0 0 0 1 -2 1 0 0 2 -2 -2 2 0 0 0 11/15 21:10:19:920
jeffreydoran
Posts: 69
Joined: Sun Oct 29, 2017 9:39 pm

Re: 2.6.9

Postby jeffreydoran » Sat Nov 16, 2019 2:44 am

de NJ2US

Entry : 9:03:09 PM Friday, November 15, 2019
C:\Program Files (x86)\OpenHPSDR\Thetis\Thetis.exe
---------stacktrace------------
at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
at Thetis.TitleBar.GetVerNum()
at Thetis.Console.SaveState()
at Thetis.Console.Console_Closing(Object sender, CancelEventArgs e)
at System.ComponentModel.CancelEventHandler.Invoke(Object sender, CancelEventArgs e)
at System.Windows.Forms.Form.OnClosing(CancelEventArgs e)
at System.Windows.Forms.Form.WmClose(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at Thetis.Console.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
-------------------------------

Entry : 9:03:24 PM Friday, November 15, 2019
C:\Program Files (x86)\OpenHPSDR\Thetis\Thetis.exe
---------stacktrace------------
at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
at Thetis.TitleBar.GetVerNum()
at Thetis.Console.SaveState()
at Thetis.Console.Console_Closing(Object sender, CancelEventArgs e)
at System.ComponentModel.CancelEventHandler.Invoke(Object sender, CancelEventArgs e)
at System.Windows.Forms.Form.OnClosing(CancelEventArgs e)
at System.Windows.Forms.Form.WmClose(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at Thetis.Console.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
-------------------------------
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 2:47 am

that is a mess :)

tried restarting? power cycling radio/pc? seen this before?

edit: you have 2.6.8 from TAPR installed and running? and then overwrote all those files with the ones from the zip? after unblocking them? because blimey, that getvernum() hasnt changed since before I owned an anan.

Richie.
jeffreydoran
Posts: 69
Joined: Sun Oct 29, 2017 9:39 pm

Re: 2.6.9

Postby jeffreydoran » Sat Nov 16, 2019 2:59 am

Richie,

I posted this info in response to your request to post -ve
I also posted the contents of errorlog.txt

No other assistance required.

7000DLE Thetis 2.6.9 a6_2 Firmware 2.0 Pre4

Thanks for all your hard work, mate.
NJ2US
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 3:02 am

Are the -ve seq messages always happening? If not what do you do to get it to occur? Do they happen with other versions of firmware?

Also, how often do you get those messages in the errorlog? every time you shutdown? Either way it is not normal.

Richie.
jeffreydoran
Posts: 69
Joined: Sun Oct 29, 2017 9:39 pm

Re: 2.6.9

Postby jeffreydoran » Sat Nov 16, 2019 3:07 am

Richie,

That post of the -ve seq was isolated to this evening. Nothing like it in prev firmwares or releases, and nothing since then.
In QSO on 160 meters with W1AEX NC3Z WU20, and did not notice or hear anything unusual until I saw the red triangle.

Jeff NJ2US
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 3:17 am

thank Jeff, some of that seq log could be fixed with a packet reordering system. It is interesting how fast it all happened,, some lines look like they are the same but probably the issues just followed the same pattern for a while. It could have just been a very short hiccup I guess if you haven't seen it happening all the time.

That other message in the error log is interesting. I added some code to log anything that producing un-trapped errors and I have not seen that one here. So will investigate.

Cheers Richie.
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sat Nov 16, 2019 3:47 am

Jeff,

ref that error log entry. Do you run norton or anything like that? only thing I can think of is that thetis.exe gets marked as malware or something like that and the function GetVersionInfo fails when you shut down. It is called during the save settings process.

Very odd.

Richie.
User avatar
K0MO
Posts: 25
Joined: Fri Dec 21, 2018 6:10 am

Re: 2.6.9

Postby K0MO » Sat Nov 16, 2019 4:07 am

ramdor wrote:UPDATE

Hi all,

Please try : https://www.dropbox.com/s/kafb2ln3dvbgx ... 6.zip?dl=0

There are quite a number of changes 'under the hood' in regards to display. Also please keep an eye out for the errorlog.txt file.

Note: use all the files in the zip

After the weekend testing, source for a6 will go off to Doug.

Cheers, Richie.

(11/3/10) a6
  • add: when using a single RX and when in panafall, the splitter between panadaptor and waterfall can be dragged up and down. Right click to recenter
  • fix: untrapped exception on shut down caused by thread time outs in power off button not waiting long enough (display_volts_amps_thead)
  • change: thread time out for multimeter_thread(s) in power off button state now based on meter delay
  • add: ErrorLog.txt created if any untrapped .NET or DirectX issues (\Users\<user>\AppData\Roaming\OpenHPSDR\Thetis\ErrorLog.txt)
  • fix: rx2 waterfall bitmap resized correctly, this would only be noticeable if you switched from panafall to waterfall on rx2
  • change: grid scale numbers flip side away from passband filter for USB/LSB/DIGU/DIGL/CWU/CWL


WoW! Fantastic work Richie!! The panafall splitter it's so smooth and flawless! :D

Can't wait for the a6 source code. Thanks!
Manny K0MO
Bryan W4WMT
Posts: 96
Joined: Sun Apr 09, 2017 10:12 pm

Re: 2.6.9

Postby Bryan W4WMT » Sat Nov 16, 2019 9:49 am

ramdor wrote:thank Jeff, some of that seq log could be fixed with a packet reordering system. It is interesting how fast it all happened,, some lines look like they are the same but probably the issues just followed the same pattern for a while. It could have just been a very short hiccup I guess if you haven't seen it happening all the time.

That other message in the error log is interesting. I added some code to log anything that producing un-trapped errors and I have not seen that one here. So will investigate.

Cheers Richie.


Hi Richie,

Thanks to Jeff, by the way, for that seq log post. Scott's earlier post of Warren's comments during the PRO development in openPowerSDR reminded me that Warren had actually found smoking gun evidence that the faulty packet ordering was happening in the stack and not on the LAN. Seem to remember they had used Wireshark to prove the packets were arriving in the correct order, but the stack was getting them out of order!

Jeff's seq log appears to reinforce Warren's position, in that his direct computer/radio connection doesn't really involve much of a LAN. I'm sure Jeff knows this, but it wouldn't hurt to double check that his network metric setting is favoring the radio's NIC (and not his LAN NIC)?

73
jeffreydoran
Posts: 69
Joined: Sun Oct 29, 2017 9:39 pm

Re: 2.6.9

Postby jeffreydoran » Sat Nov 16, 2019 10:42 am

Thanks Bryan and Richie for the comments and analysis. I am running Norton 360 on this PC. I am also using a prioritized metric on the NIC attached to the 7000DLE, which is needed to get Bootloader to properly run.

Jeff
NJ2US
User avatar
dl6eat
Posts: 40
Joined: Wed Feb 14, 2018 1:31 pm
Location: Ellerhoop - JO43VR
Contact:

Re: 2.6.9

Postby dl6eat » Sat Nov 16, 2019 11:22 am

Hi Richie,

Is the link to a6 broken? Doesn't work here right now.
Many thanks for all your good work!

73,

Andy
No knobs, Pure Signal and Thetis (open source)
ANAN 7000, ANAN 10, Intel NUC 8i7 32 GB + 16 GB Optane
User avatar
dl6eat
Posts: 40
Joined: Wed Feb 14, 2018 1:31 pm
Location: Ellerhoop - JO43VR
Contact:

Re: 2.6.9

Postby dl6eat » Sat Nov 16, 2019 11:25 am

Think should have replied to Menny as well - sri.

Also to you "many thanks for all your efforts!"

73,

Andy
No knobs, Pure Signal and Thetis (open source)
ANAN 7000, ANAN 10, Intel NUC 8i7 32 GB + 16 GB Optane
User avatar
dl6eat
Posts: 40
Joined: Wed Feb 14, 2018 1:31 pm
Location: Ellerhoop - JO43VR
Contact:

Re: 2.6.9

Postby dl6eat » Sat Nov 16, 2019 11:59 am

Sorry gents - realized it was my mistake.

I had to open Richie's original link - not one of the many copied right after. (they end up somewhere...)
Once again "many thanks for all your hard work! Very much appreciated"
I will dig into tests riht now.

Cheers and happy we,

Andy
No knobs, Pure Signal and Thetis (open source)
ANAN 7000, ANAN 10, Intel NUC 8i7 32 GB + 16 GB Optane
vk1hx
Posts: 44
Joined: Fri Sep 13, 2019 12:03 pm

Re: 2.6.9

Postby vk1hx » Sun Nov 17, 2019 2:40 am

Is anyone else noticing an increase in CPU usage with the updated 2.6.9 a6 release?

Also, loving the ability to move the divider bar.... very cool.. 8-)
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sun Nov 17, 2019 4:05 am

vk1hx wrote:Is anyone else noticing an increase in CPU usage with the updated 2.6.9 a6 release?

Also, loving the ability to move the divider bar.... very cool.. 8-)


Well it shouldn't be, and doesn't on my setup. Actually, it is doing quite a bit less work per frame now, even with the additional split calculations. Use resource mon, set display to off, get an average, and then pick panafall or something. The GC ticks off much less frequently now as well due to some other changes that went into a6.

To really bog it down (get the odd flick of the red fps warning) in directX on my system at least is to run RX1 and RX2, set the 4k scaling to 100% and run it full width. That is 3527 pixels of data, 3527 line draws just for the top of the panorama data line, another 3527 just to fill it in, so 423,240 line draws per second @ 60fps, and then double that if rx2 is displayed. So 846k lines, with various thickness, then the grid, then the waterfalls. There is not much more performance to eek out of the render code now, perhaps some in the grid stuff.

Of course, technically I could render all the grid into a bitmap and only update it if things changed, and then just plonk that direct onto the rendertarget before overlaying the spectral data..... hmmm.

Anyhow, there will be an a7 in a couple of hours to try out during Sunday which uses some caching for string size calculations as these are relatively slow as an overall % of grid frame draw time (directx only). A number of other tweaks and changes as well.

Richie.
Last edited by ramdor on Sun Nov 17, 2019 4:13 am, edited 1 time in total.
w9mdb
Posts: 126
Joined: Sun Apr 09, 2017 5:53 pm

Re: 2.6.9

Postby w9mdb » Sun Nov 17, 2019 4:12 am

I'm seeing a memory leak in MW0LGE a6_2

Over 24 hours memory usage went from 620MB to 765MB. Yesterday before I started tracking got an out of memory error.
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sun Nov 17, 2019 4:21 am

w9mdb wrote:I'm seeing a memory leak in MW0LGE a6_2

Over 24 hours memory usage went from 620MB to 765MB. Yesterday before I started tracking got an out of memory error.


I have run for days and have not noticing anything really excessive, and have run it through the memory profiler in VS2019.

That said,

a) did you have spots on?
b) did you have special panadaptor mode with backgound/sun?
c) which meter was in use edge/original
d) did you have a cat connection up and running?
e) which display mode was in use? and did it have rx2 shown?
f) are you using directX engine?

Richie.
w9mdb
Posts: 126
Joined: Sun Apr 09, 2017 5:53 pm

Re: 2.6.9

Postby w9mdb » Sun Nov 17, 2019 4:47 am

a) What spots?
b) Just Panadapter -- don't know what the background/sun thing is
c) Edge
d) One CAT connection
e) Single Rx
f) Was using GDI+ -- switched to DIrectX now to see if it makes a difference

Mike
User avatar
ramdor
Posts: 378
Joined: Wed Jul 03, 2019 3:07 pm

Re: 2.6.9

Postby ramdor » Sun Nov 17, 2019 4:50 am

well it was flat lined in directX mode for a 10min memory test. Will test gdi next.

Return to “Thetis”