Thetis 2.6.4: Major New Release

User avatar
FM5GB
Posts: 49
Joined: Sun Apr 09, 2017 10:03 pm

Re: Thetis 2.6.4: Major New Release

Postby FM5GB » Wed Apr 17, 2019 3:12 am

Hi Scott, Hi all

Thetis 2.6.4 looks great ! Thanks so much to all developpers !
I had to change my Windows (7) regional settings to have it start.
(will have to be awfully carefull when transferring money from
my bank account with the point separator)
I tested all the major functions so far : just pure joy!
Also FW P2 1.8 is making my 200D (Orion mark 1) eventually work
despite its damned serial #. I had almost lost hope.

2.6.4 is a major realease indeed. I will investigate and report in the firmware section
if there is any trouble.

73s Phil
geireri@online.no
Posts: 5
Joined: Sun Oct 28, 2018 9:45 am

Re: Thetis 2.6.4: Major New Release

Postby geireri@online.no » Wed Apr 17, 2019 7:21 am

SM4PEL. wrote:
w-u-2-o wrote:@geireri@online.no,
@SA3ATF,

This bug was just reported, see if changing your Windows regional settings helps:

"Thetis (v2.6.4) crashes on start if the regional settings use comma (',') as number fractional part separator."

73,

Scott

Yes!!! I switched regional settings to England, and now i works!!!
//Peter


worked here too but now my logging program (dxkeeper) complains about the new settings
geir
User avatar
FM5GB
Posts: 49
Joined: Sun Apr 09, 2017 10:03 pm

Re: Thetis 2.6.4: Major New Release

Postby FM5GB » Thu Apr 18, 2019 2:13 am

Same trouble here :
HRD log program does not start anymore after having changed the location in Win7.


BTW :
- Pure Signal is difficult do get working. Seems to need a lot of mike gain especially to
start correcting
- had an episode of broadcast band keyboard appearing after almost every
band change. A Thetis restart fixed it.

73s Phil
User avatar
w-u-2-o
Posts: 1738
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.6.4: Major New Release

Postby w-u-2-o » Thu Apr 18, 2019 12:57 pm

PureSignal is actually working better in Thetis with Protocol 2. The handling of IF data streams is much improved in the firmware and as a result PS performance is increased. Don't forget that you MUST hit 0dB ALC on a regular basis to get PS to kick off a correction cycle. Set up your audio processing correctly and it will all work beautifully.

It may be that some of the new default values in Thetis are thowing you off a little bit. There is an excellent video posted here that can help you get things setup just right:

https://apache-labs.com/community/viewtopic.php?f=6&t=2550
UR3IQO
Posts: 1
Joined: Thu Apr 18, 2019 6:44 am

Re: Thetis 2.6.4: Major New Release

Postby UR3IQO » Thu Apr 18, 2019 1:33 pm

FM5GB wrote:Same trouble here :
HRD log program does not start anymore after having changed the location in Win7.

It is not necessary to change the Region to start Thetis. You can just change the fractional number part delimiter to '.' (dot) in the Advanced regional settings. It might (or might not) help with other programs.

Also a bit ugly solution that should work:
Change delimiter to '.', run Thehis, change delimiter back to default value for your region (i suspect it is comma ','), now run HRD log. It should help, but it is very inconvenient...

The problem with regional settings affects only start of the Thehis. It it started it works with different regional settings, maybe this info can help to fix Thetis.

BTW, can somebody test if the audio output to computer speaker via VAC works in Thetis?

73!
Oleg UR3IQO
User avatar
w-u-2-o
Posts: 1738
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.6.4: Major New Release

Postby w-u-2-o » Thu Apr 18, 2019 1:39 pm

VAC is 100% functional.
User avatar
W1AEX
Posts: 221
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: Thetis 2.6.4: Major New Release

Postby W1AEX » Thu Apr 18, 2019 4:44 pm

Scott,

Just an observation that might be similar to what Phil is seeing. Using my 200D with firmware version 1.8 (flashed with the Bootloader) it seems that Pure Signal is not able to correct when the rig is first powered up. Initially, the feedback light will flash appropriately but the correction light will not flash and AmpView displays a confused scramble of phase and magnitude lines. After a minute or two, 160 and 80 meters will begin to correct normally. Then, about 5 minutes later the higher bands will begin to correct normally. From that point on things seem to run fine. So, it would appear that v1.8 is very close to perfect (for my FPGA) but perhaps it might not be completely optimal.

73,

Rob W1AEX
"One thing I am certain of is that there is too much certainty in the world."
User avatar
w-u-2-o
Posts: 1738
Joined: Fri Mar 10, 2017 1:47 pm

Re: Thetis 2.6.4: Major New Release

Postby w-u-2-o » Thu Apr 18, 2019 7:28 pm

W1AEX wrote:Using my 200D with firmware version 1.8 (flashed with the Bootloader) it seems that Pure Signal is not able to correct when the rig is first powered up. Initially, the feedback light will flash appropriately but the correction light will not flash and AmpView displays a confused scramble of phase and magnitude lines. After a minute or two, 160 and 80 meters will begin to correct normally. Then, about 5 minutes later the higher bands will begin to correct normally. From that point on things seem to run fine.
Ah, now that's some VERY useful information! Much better than "VAC doesn't work". This is a classic sign of an FPGA build not making timing until it warms up. Rick--please take notice of this one!

Thanks!

Scott
User avatar
FM5GB
Posts: 49
Joined: Sun Apr 09, 2017 10:03 pm

Re: Thetis 2.6.4: Major New Release

Postby FM5GB » Thu Apr 18, 2019 11:45 pm

Hi
(200D-Win7)
I noticed some weird behaviour of PS and thought first it had to do with the mike & audio chain gain. After I played with Thetis the whole day long (I have some days off for Easter). Even with the rig powered on for about 11 hours PS would not kick in some times. I could make it work by switching PS off & on and operating the PTT foot switch once or twice...

I tweaked the poor little Thetis as much as I could.
At its limits : sample rates at 1536000 RX1 & RX2 I can see (quite rarely) the seq error indication light up under the RX windows without any noticeable dropout or glitch. I never brought Thetis to hang (FW 1.8 seems really stable)
After some minutes (hours) of trying, including PS testing I lost power output and got a mixup in the TX meter on RX 1. I tried to stop & restart Thetis but It would not lauch anymore showing same error as with the windows location bug.
After removing all the database files from the Thetis folder every thing recovered and importing a sane database brought me back in business in a minute.
The tandem Thetis 2.6.4/FW 1.8 has become incredibly stable

73s Phil
User avatar
W1AEX
Posts: 221
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: Thetis 2.6.4: Major New Release

Postby W1AEX » Fri Apr 19, 2019 3:17 am

A nice surprise from Doug tonight as Thetis v2.6.5 has been released at the TAPR GitHub repository:

https://github.com/TAPR/OpenHPSDR-Thetis/releases

I gave it a brief run and it behaved very nicely with my ANAN-200D from 160m - 6m. The long shutdown experienced with v2.6.4 was certainly addressed as Thetis now closes up instantly and cleanly. The database import utility converted the database I made for v2.6.4 without any problem at all. I'm sure details will follow about what was addressed but it behaved very well for me during a short session.

Thanks very much Doug!

73,

Rob W1AEX
"One thing I am certain of is that there is too much certainty in the world."
NC3Z
Posts: 153
Joined: Sun Oct 29, 2017 8:57 pm
Location: Merritt, NC

Re: Thetis 2.6.4: Major New Release

Postby NC3Z » Fri Apr 19, 2019 11:34 am

Hmmm, no release notes, wonder what else was done?
Gary NC3Z

Return to “Thetis”