Thetis, poor VAC audio quality, and the resampler

User avatar
w-u-2-o
Posts: 1497
Joined: Fri Mar 10, 2017 1:47 pm

Thetis, poor VAC audio quality, and the resampler

Postby w-u-2-o » Sun Dec 09, 2018 9:15 pm

If you are experiencing poor VAC audio quality with Thetis it is probably because you are not using the resampler properly. You can either turn it off completely, or develop some VAC settings that make it operate in a stable fashion. The latter is more work, but the reward is better audio quality than not using it.

To turn off the resampler, click the "Force" checkboxes in the resampler, and leave the setting below each box at 1.0000.

If you want to use the resampler, but it is unstable, that is the under and overflow counters are steadily increasing, you have to get it to a stable configuration.

Instructions for resampler adjustment are here:

https://apache-labs.com/community/viewtopic.php?f=6&t=2763

However, those instructions are for PowerSDR. In Thetis beta there is also an adjustment called "PortAudio". I recommend you set both PortAudio settings to manual and make the settings 0 to start with. Or go with the complete opposite, set everything to automatic.

BOTTOM LINE: if your overflow and underflow counters are steadily increasing then you are not going to be happy with the results and you must find settings that cause them to be stable. You can click on them to reset them to zero if the numbers get too big to follow properly.

Return to “Thetis”