Work Split Digimodes possible bug?

User avatar
G0MGM
Posts: 34
Joined: Sun Apr 09, 2017 2:38 pm
Location: Bourne End
Contact:

Work Split Digimodes possible bug?

Postby G0MGM » Sun Aug 13, 2017 9:04 am

Just wondering if anyone else can confirm or if its a known bug but I was just trying to work some MSK144 on 6m Meteor Scatter and I had set my Tx freq to 50.280 and Rx on 50.285, when I try to tx I get no modulation or power output on 50.280 but the Anan keys OK.

I then tried a similar set up on 20m using FT8 or JT65 and I get the same. If I then work simplex by not setting Split, modulation and power is then seen on both 20m and 6m. All of these tests were carried out using WSJTx v1.8.0-rc1 and with MSHV for MSK144 with no changes to the VB audio settings.

No changes were made other that selecting the Split function to make modulation and power return to normal. Not tried it on other digimodes but suspect its the same.

Rob
User avatar
w-u-2-o
Posts: 2368
Joined: Fri Mar 10, 2017 1:47 pm

Re: Work Split Digimodes possible bug?

Postby w-u-2-o » Mon Aug 14, 2017 1:49 pm

Rob,

Bottom line up front: there would appear to be no way to do this in WSJT-X the way that application is currently written.

Recommendation: contact the author, K1JT, and ask him to fix it. Have him add native support for Windows PowerSDR mRX and fix the issue described below.

Discussion: this is not something I normally do, but I had noticed this problem in the past and was intrigued by your question. Fldigi can do this no problem, but not WSJT-X. Indeed, WSJT-X can't talk to PowerSDR except by setting WSJT-X to use Kenwood TS-2000 CAT commands.

Split mode settings in WSJT-X are a bit strange. They make some assumptions that you only want to work split within say a 3 or 4KHz passband. To get the radio to utilize a true split configuration, in the radio, set the WSJT-X split mode to "None". Then set up a split configuration in the radio. Doing this, I found that the first transmission by WSJT-X did go out on the correct split TX frequency, however when PTT was de-asserted WSJT-X would very unhelpfully write the RX dial frequency into VFO-B, thereby negating the split for all subsequent transmissions.

I then thought a crude work-around might be to just use serial port PTT instead of CAT PTT. However WSJT-X provides no option for that. There is no radio type selection that will allow that. Choosing "None" shuts off serial port PTT!

There might be a way to finagle this by washing everything through DX Commander, however I did not go through the exercise of trying this.

Again, I'd recommend you contact Joe. I've never had any correspondence with him, but from hearsay it would appear he is quite approachable.

73!

Scott
w9mdb
Posts: 151
Joined: Sun Apr 09, 2017 5:53 pm

Re: Work Split Digimodes possible bug?

Postby w9mdb » Mon Aug 14, 2017 1:57 pm

Contact me and I can probably help you out.

I've never had split problems like you describe so something is funky with your setup.

mdblack98@yahoo.com

de Mike W9MDB
User avatar
w-u-2-o
Posts: 2368
Joined: Fri Mar 10, 2017 1:47 pm

Re: Work Split Digimodes possible bug?

Postby w-u-2-o » Mon Aug 14, 2017 3:37 pm

Mike,

It would be nice if you could publish the fix here so that we could all benefit from it, since I am having the same problem.

Thanks & 73,

Scott
User avatar
G0MGM
Posts: 34
Joined: Sun Apr 09, 2017 2:38 pm
Location: Bourne End
Contact:

Re: Work Split Digimodes possible bug?

Postby G0MGM » Mon Aug 14, 2017 4:33 pm

Thanks for the replies.

I have had it working in the past with MSHV and WSJT-x as I have done some Meteor Scatter QSOs that way when I had PSDR MRx running but I will try HRD and FL-Digi and see if I get the same result.

Will post back.

Rob
User avatar
G0MGM
Posts: 34
Joined: Sun Apr 09, 2017 2:38 pm
Location: Bourne End
Contact:

Re: Work Split Digimodes possible bug?

Postby G0MGM » Mon Aug 14, 2017 4:47 pm

OK I have just tried it with FL-Digi and I seem to be getting the same results.

In the picture attached I have set 14.106 to be my Rx freq and 14.109 to be my Tx freq. Split is checked and when I set FL_digi to tx the Anan keys up and I see that the Panadapter screen does not change frequency to 14.109 and I see no modulation, in this case RTTY.

Rob
Attachments
Thetis split.JPG
Thetis split.JPG (195.93 KiB) Viewed 3574 times

Return to “Thetis”