Performance Issue with piHPSDR version 1.2.3

Posts: 1
Joined: Sat Dec 16, 2017 9:28 am

Performance Issue with piHPSDR version 1.2.3

Postby wn7t » Wed Feb 14, 2018 5:06 am

Greeting to all!
I have a piHPSDR control head in use with an Anan 7000DLE.
Using the controller with factory issued SW version 1.0.7 the unit operated flawlessly.
I recently updated to version 1.2.3 piHPSDR sw.
I really like the expanded feature set (dual VFOs & advanced noise reduction), but lately I have noticed platform jitter with the waterfall becoming “jerky” and transitory audio artifacts heard during RX. The issues seem to arise after several minutes of RX time.
The LINUX CPU performance monitor shows about 37% usage while the performance degradation is occurring.
The SW upgrade followed John’s advice to rename/delete the original piHPSDR folder to avoid GPIO pin assignment issues.
Has anyone else encountered similar performance degradation?
I could always reinstall ver. 1.0.7, but that seems a bit atavistic.
I am guessing this may be due to system clock error between the raspberrypi cpu and Orion II cpu.
piHPSDR VER. 1.2.3 built 2017-12-28
S. No PiHPSDR0058
WDSP ver. 1.16
Directly connected by CAT6 LAN cable to:
Anan 7000DLE
S. No 7000DLE0030
Orion II protocol 1 firmware version 2.1
Any insight to this performance glitch would be much appreciated.
Paul WN7T
Posts: 16
Joined: Tue Apr 11, 2017 9:43 pm

Re: Performance Issue with piHPSDR version 1.2.3

Postby wb2ems » Fri Feb 23, 2018 3:45 am

Hi Paul,

I tried to upgrade to 1.2.3 also and see somewhat similar results. I always see a stuttering every 60 seconds like clockwork, but as I let the system run, I was seeing more and different stuttering similar to what you describe. Mine was a new build with fresh raspbian and followed the instructions to build the current release. For now I've reverted to 1.1.3. My setup is an Anan 200 D via wireless.

I was having additional issues with the knobs being incorrectly mapped, where did you see Johns advice about renaming a directory? Since mine was a new build, it probably didn't matter for me, but I'd still like to see what is recommended as I'm having no luck getting things mapped correctly in the new version. I tried copying the .prop files from the working version to the new one and while the gpio assignments show the same, it still doesn't work. I'm new to all this and working from a version someone else built, so I don't have the information on how the encoders are wired so I'm trying to use the information from the old version and propagate it forward.

Has anyone run version 1.2.2, and can it be loaded instead? Does it have similar issues?

Kevin, WB2EMS

Return to “piHPSDR”