mRx 3.4.9 not saving settings reliably - Win10

N7CXI
Posts: 46
Joined: Sun Apr 09, 2017 5:20 pm

mRx 3.4.9 not saving settings reliably - Win10

Postby N7CXI » Fri Oct 11, 2019 4:19 pm

I'm having some difficulties getting PowerSDR mRx 3.4.9 to save settings reliably. I've seen this behavior with three radios and three PCs now, and have deleted databases and started raw many time. One of the PCs is very fast but has some miles on it and is a dev box. The other two are literally brand new DIY Windows 10 Pro installations, fully patched as of 2019-10-11 . CPUs are i7s, lots of RAM, SSDs etc. Network is gigabit Ethernet connected by a fabric-speed layer 2 switch. (no VLANS or other fancy-pants stuff going on)

What I mean by "save setting reliably" is: (for example)
- Set PA calibration on 80m (8000DLE and 7000DLE MKII, other settings on Angelia-only rig)
- Click "Apply"
- Move the mouse over and click "Ok". Nothing visible happens. (dialog doesn't close) ??
- Wait 30 seconds, click "OK" again. Dialog closes.
- Operate, gab, perform meaningful communications-related tasks
- Click the PowerSDR "Power" button OFF
- Wait 30 seconds
- Close the program, shut down the PC (legally), walk away
- Next day - boot up, power up radio, launch PowerSDR. * PA calibration has not "stuck" *

So - since there isn't a thundering herd complaining about this, I'm assuming it's being caused by something I'm doing or not doing. Is there any normal manipulation of controls that can cause a "snap back" effect like this? Could UAE be a factor? Is there any error log or debug spew if there's a problem writing the XML?

Last bit: I do run AM regularly, and the other gent that's experiencing this does as well. Other than that, we have different hardware and PC's. We both fiddle with mic, EQ and compressor settings, and sometimes save tweaks on TX profiles - carrier levels, filter limits et al.

Speculation and suggestions welcome, thanks!

73,
Jim N7CXI
User avatar
w-u-2-o
Posts: 2772
Joined: Fri Mar 10, 2017 1:47 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby w-u-2-o » Fri Oct 11, 2019 5:22 pm

Jim,

FWIW, I am unable to duplicate this problem.

It should not matter what PC or what radio hardware you are using.

Do other settings get saved? Is it only the PA calibration data that is not getting saved?

73,

Scott
N7CXI
Posts: 46
Joined: Sun Apr 09, 2017 5:20 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby N7CXI » Fri Oct 11, 2019 5:32 pm

w-u-2-o wrote:Jim,
Do other settings get saved? Is it only the PA calibration data that is not getting saved?


Hi Scott,
Thanks for (still!) being here.

The two that have been repeat offenders are the PA calibration and the AM carrier level. One other than comes to mind is the per-band last frequency. Once new installations have a few hours on them PowerSDR stops remembering the last frequency used when changing bands.

One direct question for you: If you [make some Settings dialog change] then click "Apply", then immediately click "Ok", does the dialog close? The fact that it doesn't on these PC's/Winvers might be a clue, unless it's expected behavior.

Thanks and 73,
Jim N7CXI
User avatar
w-u-2-o
Posts: 2772
Joined: Fri Mar 10, 2017 1:47 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby w-u-2-o » Fri Oct 11, 2019 5:40 pm

Jim,

I have seen the dialogue hesitate to close upon occasion. This implies it is taking a long time to write the database.xml file, something that should not be true.

It seems like a difficult to reproduce bug in PowerSDR.

I often have the last frequency utilized not be remembered. I also have the "Fwd Pwr" meter setting not be remembered. But I've never had a problem with PA cal. or AM carrier level.

73,

Scott
N7CXI
Posts: 46
Joined: Sun Apr 09, 2017 5:20 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby N7CXI » Fri Oct 11, 2019 5:46 pm

Interesting, thanks.

Speculating out loud, I do run PowerSDR with "realtime" priority, which may not be the best choice. I suppose it's *possible* that something in the file system isn't inheriting the priority and a thread is getting stalled.

- or something completely different.

What I do know is that it's a pain overall, and bears investigation. I have sterling intentions, but coming up with the time to build the sources and debug it is difficult.

73,
Jim N7CXI
User avatar
w-u-2-o
Posts: 2772
Joined: Fri Mar 10, 2017 1:47 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby w-u-2-o » Fri Oct 11, 2019 6:11 pm

I do not believe the process priority setting actually makes any difference in how the application operates these days. I run mine on normal.
User avatar
ramdor
Posts: 380
Joined: Wed Jul 03, 2019 3:07 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby ramdor » Fri Oct 11, 2019 7:42 pm

There are a couple of issues with the save settings.

In powersdr :

a) dialog will not close if ok is pressed and the save thread is currently saving (caused by c)

b) when ok is pressed, and not saving, a thread will start to save the settings, saving flag is set during the save, the window will hide

c) if apply is pressed a thread will start and try to save, unless already saving

d) if cancel is pressed, a thread will start that reads in the old options, instantly hide the window, essentially undoing any change, it does not care if settings are being saved (which is perhaps bad)

Problems :

1) if you hit apply, and then ok, window will not close if it is still in the middle of saving from the apply button press

2) d can happen even when a thread is mid way through saving the settings. Cancel should wait until any saving is completed, and then cancel

However none of this really explains why your PA settings are not being saved.

Richie.
N7CXI
Posts: 46
Joined: Sun Apr 09, 2017 5:20 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby N7CXI » Fri Oct 11, 2019 7:52 pm

Hi Richie,

I'm not sure why it would take upwards of 30 seconds for the save operation to take place. The CPU is just above idle, the file systems are SSD and the filesize isn't all that large. That does give me somewhere to look and tells me I shouldn't use the "Apply" button, though. Just click "OK" and leave it until the dialog goes away.

I'm installing VS 2013 on a machine. If I can squeeze out a few hours this weekend perhaps I can learn why all this is occurring, or at least whether I have time to tear it apart.

Thanks and 73,
Jim N7CXI
User avatar
ramdor
Posts: 380
Joined: Wed Jul 03, 2019 3:07 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby ramdor » Fri Oct 11, 2019 8:30 pm

N7CXI wrote:though. Just click "OK" and leave it until the dialog goes away.


yes, just remember, it could still be saving after it has gone away.

To do a save, it recursively makes a list of every single setupform check box, text box, combo box, up down, radio button, track bar and colour button, then it loops through all those components, taking their values/settings/text and stores it. There are over 1800 controls to save out in Thetis (not sure about powersdr) which takes anywhere up to 14 seconds in debug mode, which is a long time.

If it is in the middle of doing any of this, and you make more changes, and then hit apply/ok well, it is anyone's guess what will get saved depending on how far through the save thread and which component is being stored.

Richie.
N7CXI
Posts: 46
Joined: Sun Apr 09, 2017 5:20 pm

Re: mRx 3.4.9 not saving settings reliably - Win10

Postby N7CXI » Fri Oct 11, 2019 9:18 pm

ramdor wrote:
N7CXI wrote:though. Just click "OK" and leave it until the dialog goes away.


yes, just remember, it could still be saving after it has gone away.

To do a save, it recursively makes a list of every single setupform check box, text box, combo box, up down, radio button, track bar and colour button, then it loops through all those components, taking their values/settings/text and stores it. There are over 1800 controls to save out in Thetis (not sure about powersdr) which takes anywhere up to 14 seconds in debug mode, which is a long time.

If it is in the middle of doing any of this, and you make more changes, and then hit apply/ok well, it is anyone's guess what will get saved depending on how far through the save thread and which component is being stored.

Richie.


1800 controls! Wow. I know nothing about the internals, but from the outside at least that sounds like a candidate for a state struct.
Good info, The takeaway is don't click "Ok" more than once every 30 seconds or so. That could very well be my problem.

Thanks!
Jim N7CXI

Return to “PowerSDR mRX”