PowerSDR mRX PS 3.4.6 Released

w5wc
Posts: 13
Joined: Wed Apr 05, 2017 3:29 am

PowerSDR mRX PS 3.4.6 Released

Postby w5wc » Thu Nov 23, 2017 12:18 am

PowerSDR mRX PS 3.4.6 has been released. This release corrects the problem of having a blank waterfall display in the Panafall mode while transmitting.

https://github.com/TAPR/OpenHPSDR-PowerSDR
User avatar
WA0VY
Posts: 83
Joined: Sun Apr 09, 2017 3:41 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby WA0VY » Thu Nov 23, 2017 1:09 am

73 Brent WA0VY
User avatar
W1AEX
Posts: 220
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: PowerSDR mRX PS 3.4.6 Released

Postby W1AEX » Thu Nov 23, 2017 3:48 am

Thank you Doug and Happy Thanksgiving!

73,

Rob W1AEX
"One thing I am certain of is that there is too much certainty in the world."
User avatar
Tony EI7BMB
Posts: 265
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: PowerSDR mRX PS 3.4.6 Released

Postby Tony EI7BMB » Thu Nov 23, 2017 12:41 pm

Thanks Doug
User avatar
W1AEX
Posts: 220
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: PowerSDR mRX PS 3.4.6 Released

Postby W1AEX » Thu Nov 23, 2017 4:20 pm

The panafall is behaving correctly for me now during TX and I should also mention that the CTUN feature is behaving very nicely. Thank you for chasing down these items and the other little annoyances that popped up between 3.4.3 and 3.4.6. I appreciate all the effort it takes to produce these quick updates and also appreciate how painless it is to apply these kinds of updates with the magnificent automatic (actually automagic is more accurate) database importation utility! Thanks again for all the work you guys are doing!

73,

Rob W1AEX
"One thing I am certain of is that there is too much certainty in the world."
AB2EZ
Posts: 94
Joined: Sun Apr 09, 2017 2:29 pm
Location: Princeton, NJ

Re: PowerSDR mRX PS 3.4.6 Released

Postby AB2EZ » Thu Nov 23, 2017 4:33 pm

I would like to add my thanks to the entire team for all of the great work you do. Providing software, firmware, on-line support, and new releases for seven different ANAN-X platforms (not including various models of connected PCs and auxiliary applications) is a herculean task.

Happy Holidays!

Stu
w5wc
Posts: 13
Joined: Wed Apr 05, 2017 3:29 am

Re: PowerSDR mRX PS 3.4.6 Released

Postby w5wc » Thu Nov 23, 2017 4:39 pm

All the thanks for hunting down and fixing the long annoying issues with the database and CTUN go to Chris. Without his help I would have to keep saying "Reset your database". What a relief it is not having to make everyone so grumpy over updating the software.

73, Doug W5WC
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Thu Nov 23, 2017 6:58 pm

That would be Chris, W2PA :)

Great stuff, all!

73!

Scott
AB2EZ
Posts: 94
Joined: Sun Apr 09, 2017 2:29 pm
Location: Princeton, NJ

Re: PowerSDR mRX PS 3.4.6 Released

Postby AB2EZ » Fri Nov 24, 2017 7:29 pm

I have observed a minor problem with releases starting with 3.4.4...

Transceiver: ANAN-10E

Problem:

On 40 meters

When I activate "TUN" on the main HPSDR GUI, my separate RF output power meter reads 100W, the S-ATT auto setting is 20dB... and the panadapter display reads -5dBm. Note that I am using a Elecraft 100W amplifier, with Pure Signal active, and the Pure Signal feedback to the ANAN-10E coming from the amplifier output.

However, when I activate "Tune" on may WSJT-X application, all of the above is the same... except... the panadapter display reads +6.5dBm

On 30m, the panadapter display using HPSDR TUN is +2dBm, and the panadapter display using WSJT-X is +9.5dBm. In both cases, the amplifier power output is 96W and the S-ATT auto setting is 23dB. Note that the coupler I am using has approximately 3dB less coupling loss on 30m than it has on 40m... which is why the S-ATT setting is approximately 3dB higher on 30m than it is on 40m

On 20m, the panadapter display using HPSDR TUN is +8.5dBm, and the panadapter display using WSJT-X is +13dBm. In both cases, the amplifier power output is 96W and the S-ATT auto setting is 26dB. Note that the coupler I am using has approximately 6dB less coupling loss on 20m than it has on 40m... which is why, for the same amplifier output power, the S-ATT setting is approximately 6dB higher on 20m than it is on 40m

Stu
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Fri Nov 24, 2017 10:05 pm

Stu,

If I'm reading this right, your feedback path loss is 47dB on 40M, 44dB on 30M and 41dB on 20M. Is that correct?

73,

Scott
AB2EZ
Posts: 94
Joined: Sun Apr 09, 2017 2:29 pm
Location: Princeton, NJ

Re: PowerSDR mRX PS 3.4.6 Released

Postby AB2EZ » Sat Nov 25, 2017 12:22 am

Scott

On 40m, the feedback path loss is 50dBm - 6.5dBm = 43.5dB
On 30m the feedback path loss is 50dBm - 9.5dBm = 40.5dB
On 20m the feedback path loss is 50dBm - 13dBm= 37dB

The coupler consists of a 20dB voltage divider followed by a second voltage divider consisting of: a 50 ohm resistor in series with an inductor (to ground). The inductor has an impedance on 40m of approximately j3.5 ohms.

Physically the 20dB voltage divider is a 1 turn-to-10 turn current transformer... which looks into the 50 ohm (approximately) input impedance of the second voltage divider.

The second voltage divider consists of a 50 ohm resistor connected in series with the RX1 input impedance of the ANAN-10e. When transmitting, the RX1 input impedance is the impedance looking into the length of 50 ohm mini-coaxial cable that runs between the RX connector and the relay that grounds that center conductor of this cable on transmit. The end of this mini-coaxial cable that is connected to the RX connector does not look like a short to ground. It looks like an inductor to ground.

[The inductance per foot can be calculated from basic principles... given that the characteristic impedance of the cable is 50 ohms, and the capacitance of the cable is roughly 30pf per foot. L= C x 50 ohms x 50 ohms = 30 x 10**-12 farads/ft x 50 ohms x 50 ohms = 0.075uH/ft

A 1ft length would have an impedance at 7MHz of: Z= j x 0.075 x 2pi x 7 ohms = j3.3 ohms]

Stu
Last edited by AB2EZ on Sat Nov 25, 2017 5:33 pm, edited 4 times in total.
User avatar
DL2XY
Posts: 32
Joined: Sun Jul 30, 2017 9:47 am

Re: PowerSDR mRX PS 3.4.6 Released

Postby DL2XY » Sat Nov 25, 2017 10:36 am

Hi,

I can confirm the issue.

In tune mode spectrum and waterfall displays are showing much less signal.
The difference depends on band selection.
VAC, MIC and internal Signal Generator inputs are showing correct values.
Output power is not effected.

edit:
Changing S-ATT in TUN cancels the difference.
Changing S-ATT in MOX restores the difference.



73 Walter [DL2XY]
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Sat Nov 25, 2017 3:00 pm

I can easily duplicate this problem. On 160M, on the 8000, I have a 10dB difference :shock: between asserting 100W with TUN, and asserting 100W using a tone (I used Fldigi). This 10dB difference on TUN disappears as soon as I move the step attenuator once in any direction.

This has caused me to make very careful measurements of feedback path loss. Given that the Xtronic couplers are ruler flat from 160 to 10M, and that mine has always exhibited 44dB of coupling loss, I've noticed that there is additional path loss in the 8000 feedback path and that it has quite a bit of tilt. Using the feedback path and DUP, with my external power meter reading 100W (50dBm), I observe:

On 10M DUP is measuring +3, should be +6, and PS is setting S-ATT to 16, but should be 19.
On 160M DUP is measuring 0, should be +6, and PS is setting S-ATT to 13, but should be 19.

This is somewhat disturbing :?

I have a few more measurements I need to make now. I may start a new thread on this in the PureSignal sub-forum depending on how those measurements turn out.
User avatar
Prem
Posts: 76
Joined: Tue Apr 11, 2017 11:57 am
Location: UAE
Contact:

Re: PowerSDR mRX PS 3.4.6 Released

Postby Prem » Sat Nov 25, 2017 5:40 pm

Hi Scott,

I have installed 3.4.6 and notice that when VOX enable, MOX get enables.
Please have a look and advice it is due to some trouble in my system ?

73s,

Prem
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Sat Nov 25, 2017 10:06 pm

Prem wrote:Hi Scott,
I have installed 3.4.6 and notice that when VOX enable, MOX get enables.
Please have a look and advice it is due to some trouble in my system ?
Prem--I'm not exactly sure what you are trying to say.

Are you saying that as soon as you turn on VOX the radio goes into transmit? If so then there must be sounds or noise on the microphone audio input that is above the VOX threshold. You can plainly see if this is true by looking at the VOX meter right next to the VOX button.

Or are you saying that when you turn on VOX, and you speak, the MOX button lights up when VOX causes a transmission? This latter behavior is normal.
DO2ZA Erwin
Posts: 39
Joined: Fri Apr 21, 2017 4:49 pm

Re: PowerSDR mRX PS 3.4.6 Released BUG ??

Postby DO2ZA Erwin » Sun Nov 26, 2017 3:28 pm

Hello Guys,

I see also a different in the Display when I use the Tune button, the Peak is now around -40 before 3.4.6 it was around 0 to -10 I think??
The HF-Output is still ok.

Also the ATT-Level for Pure Signal is now 0, before 3.4.6 (5) it was around -4 db on 80 m. The Feedback-Level on Pure-Signal is around 173, before it was around 145-150. Sorry, forget: I use only the intern Sampler from the ANAN 200 D Rev. 24

And the VFO-Lock works only for VFO A not for VFO B !! I m not shure is it a new or an old Bug ??

73 Erwin
Last edited by DO2ZA Erwin on Sun Nov 26, 2017 6:17 pm, edited 2 times in total.
Anan 200D rev.24, WIN 10, freezed at 10.0.1734.1099 (1803), i7-7700 @3.60 Ghz, 2x Monitor 24"
User avatar
Prem
Posts: 76
Joined: Tue Apr 11, 2017 11:57 am
Location: UAE
Contact:

Re: PowerSDR mRX PS 3.4.6 Released

Postby Prem » Sun Nov 26, 2017 3:29 pm

Hi Scott,

It was some configuration error locally in my machine !
Now I find it is ok. No error.

73s
Prem
KE4CQ
Posts: 1
Joined: Fri Apr 21, 2017 10:25 am

Bug with AGC gain control on 3.4.6

Postby KE4CQ » Wed Nov 29, 2017 2:31 am

Running 3.4.6 on my 200D.

Step 1: Raise or lower your AGC gain control by moving the green line up or down.
Step 2: Open your setup tab.
Step 3: Close your setup tab (select cancel).
Watch what happens to your AGC gain immediately after closing your Setup tab. Mine moves to a different setting - raised up higher (green line goes down).

Is this happening to you?

Kevin,
KE4CQ
liam
Posts: 17
Joined: Mon Apr 10, 2017 7:26 am

Re: PowerSDR mRX PS 3.4.6 Released

Postby liam » Wed Nov 29, 2017 9:43 am

8000dle with Win 10

I installed 346 straight over 342 and got quite a few problems
I used Revo to uninstall and remove all Reg entries with a deep scan for associated
files . reinstalled and Its now working great looking very stable


Thanks for all the work

Liam
G3NPI
Posts: 29
Joined: Wed Apr 12, 2017 3:23 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby G3NPI » Wed Nov 29, 2017 11:40 am

I have just upgraded to 3.4.6 direct from 3.4.2. Lots of great changes, however, I use the XVTR feature to control a couple of transverters via the General/ANAN Cntrl feature and find only one, (VHF7) now works. It appears that the binary output volts have disappeared or only the first selection in XVTR is active, which seems the most likely as the frequency does not change. Is there a new setup step I am missing?
Using ANAN10, WIN10 (no creator upgrade)

I wonder if anybody else has this problem?

73

Geoff G3NPI
G3NPI
Posts: 29
Joined: Wed Apr 12, 2017 3:23 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby G3NPI » Wed Nov 29, 2017 12:12 pm

A correction to my earlier post. It appears that only VHF0 is active in V3.4.6

73

Geoff G3NPI
User avatar
Prem
Posts: 76
Joined: Tue Apr 11, 2017 11:57 am
Location: UAE
Contact:

Re: PowerSDR mRX PS 3.4.6 Released

Postby Prem » Wed Nov 29, 2017 12:28 pm

Hi Kelvin,

In my set up with Hermes, I notice my AGC gain jump to 93 when I open set up screen and cancel it to close ! Hope our Master Scott will also have a look into this.

73s

Prem
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Wed Nov 29, 2017 4:00 pm

Away from the shack for a few days, so no chance to look at any problems until the weekend :(
G3NPI
Posts: 29
Joined: Wed Apr 12, 2017 3:23 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby G3NPI » Thu Nov 30, 2017 2:06 pm

Well since my previous posts, I did a complete reinstall using v3.4.6 which has fixed the problem with XVTR.
Prem, I confirm I am getting the same jump of AGC gain even after the complete reinstall.

73

Geoff G3NPI
User avatar
Tony EI7BMB
Posts: 265
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Bug with AGC gain control on 3.4.6

Postby Tony EI7BMB » Thu Nov 30, 2017 5:11 pm

Noticed the step attenuator coming on also



KE4CQ wrote:Running 3.4.6 on my 200D.

Step 1: Raise or lower your AGC gain control by moving the green line up or down.
Step 2: Open your setup tab.
Step 3: Close your setup tab (select cancel).
Watch what happens to your AGC gain immediately after closing your Setup tab. Mine moves to a different setting - raised up higher (green line goes down).

Is this happening to you?

Kevin,
KE4CQ
User avatar
WA0VY
Posts: 83
Joined: Sun Apr 09, 2017 3:41 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby WA0VY » Thu Nov 30, 2017 7:29 pm

I can confirm these findings with two additions:

1. Waterfall high/low levels and spectrum grid levels also changed.
2. I am using the resampler version of 3.4.2, not 3.4.6.

So, it would seem that this glitch may not be new.
73 Brent WA0VY
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Fri Dec 01, 2017 3:00 pm

OK, gent's, back from travel...

a) This is not a new bug or behavior.
b) It's not specific to AGC, it affects a lot of things associated with the program current state.
c) The bug is associated with how and when PowerSDR stores it's current state into the database. This is all the information necessary so that when you switch bands, or from band stack register to band stack register, or close and re-open the program, everything is just the way you left it.

So what's happening is that, when you close the Setup window with the "Cancel" button, it is oh so helpfully taking you back to the previous current state. If you close it with the "OK" button, or with the "X" box, it will not exhibit the behavior you are seeing because it accepts the changes as the new current state of the software. I should also mention that clicking "Apply" and then "Cancel" does not help, as "Cancel" overrides "Apply".

All of this behavior most like dates back to the original, legacy Flex version of PowerSDR. My understanding is that the UI code in those days was quite a mess, and remains so to this day, with a vast number of weird dependencies, and this has a lot to do with these sort of things.

The community desperately needs software developers interested in UI design and development. Sadly, I'm not a software developer. If you know of any, please see if you can talk them into working on PowerSDR and Thetis ;)

73!

Scott
spinomaly
Posts: 33
Joined: Fri Oct 20, 2017 5:44 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby spinomaly » Fri Dec 01, 2017 11:44 pm

Now that I have a 7000 I am happy to help with development. Let me know how I can help. I have 3.4.2 compiling and can move to another branch as needed.
Dr. Loren Betts
W6VH
jeffreydoran
Posts: 51
Joined: Sun Oct 29, 2017 9:39 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby jeffreydoran » Sun Dec 03, 2017 6:05 pm

Scott has pointed out some of the known bugs from legacy code, much appreciated. I apologize if this has been noted before, but one of the more annoying bugs is when switching to AM mode, the DSP Buffer Sizes default back to RX=64, TX=128, and Filter type changes back to Linear Phase.

Jeff NJ2US
User avatar
w-u-2-o
Posts: 1735
Joined: Fri Mar 10, 2017 1:47 pm

Re: PowerSDR mRX PS 3.4.6 Released

Postby w-u-2-o » Sun Dec 03, 2017 10:48 pm

Jeff,

It doesn't do that for me. However, I have a bunch of Transmit Profiles set up, and when I change modes it automatically abides by my Transmit Profiles. Perhaps you need to devise and store some profiles?

73,

Scott

Return to “PowerSDR mRX”