anan 7000 and pc issue

Post your awesome projects here for everyone to marvel at!
ik7ytt
Posts: 48
Joined: Tue Mar 12, 2019 11:48 am

anan 7000 and pc issue

Postby ik7ytt » Thu Mar 28, 2019 5:07 pm

i was using anan 7000 in this days with a mini pc , i work fine for me and have this setup i5/8gb/ssd/100 bit lan trought router pc. All was ok.

Then i also setup my laptop with same configuration. may be is just a little bit slower but was all ok.

Then i bought a new computer i78/8gb/ssd/ 2 gigabit lan. also this one is mini pc.

i also set all in same way.

but with this new pc that shuold be the faster one I have problem in rx and tx.

The signale generate as Tune and in SSB is not clear (with software ps-a activated) i also i have a king of feedback and some clipping in rx.
the spectum of my emission on power sdr mRX is also not clear.

I see the cpu is always at 35/40% . With old one instead was 20/25%

Is possible that if computer is not fast enough i have this problems?
Also if have direct and faster Ethernet connection?
Both RX/tx are not trought VAC but directly to the radio. because i know that changing the pc/audio was also another problem with settings


thanks
Andy ik7ytt
User avatar
w-u-2-o
Posts: 1888
Joined: Fri Mar 10, 2017 1:47 pm

Re: anan 7000 and pc issue

Postby w-u-2-o » Thu Mar 28, 2019 5:53 pm

Are you saying that both the new PC and the radio are connected via the router? If not, then how are they connected, and what are you using both NICs for on the new computer?
ik7ytt
Posts: 48
Joined: Tue Mar 12, 2019 11:48 am

Re: anan 7000 and pc issue

Postby ik7ytt » Thu Mar 28, 2019 6:16 pm

old i5 and anan was conneted to router.

new i7 has 2 lan so is connected 1 lan to router and 1 to anan. following w1aex setup.
so the kind of lan used don't change the result....for the problem i have.

Generally if a 2 lan conncetion is faster/usefull i cannot judge for the moment


w-u-2-o wrote:Are you saying that both the new PC and the radio are connected via the router? If not, then how are they connected, and what are you using both NICs for on the new computer?
User avatar
w-u-2-o
Posts: 1888
Joined: Fri Mar 10, 2017 1:47 pm

Re: anan 7000 and pc issue

Postby w-u-2-o » Thu Mar 28, 2019 7:21 pm

OK, two more questions:

1. Did you adjust network metrics on both NICs as per Rob's instructions?

2. Did you set the two NICs to different subnets? Just as an example, your main NIC would be on 192.168.1.1 (probably using DHCP from your router) and your radio NIC would be on 192.168.5.1 (using static IP addressing).

If not, make both of those changes and see how that works out.

Also, when using a dedicated radio NIC with a static IP address, you must set the radio to use a static IP on the radio subnet. You will need to use HPSDR Programmer or HPSDR Bootloader to do that.
ik7ytt
Posts: 48
Joined: Tue Mar 12, 2019 11:48 am

Re: anan 7000 and pc issue

Postby ik7ytt » Tue Apr 09, 2019 1:59 pm

pls check my reply below

w-u-2-o wrote:OK, two more questions:

1. Did you adjust network metrics on both NICs as per Rob's instructions?

YES DONE CORRECTLY

2. Did you set the two NICs to different subnets? Just as an example, your main NIC would be on 192.168.1.1 (probably using DHCP from your router) and your radio NIC would be on 192.168.5.1 (using static IP addressing).

YES DONE CORRECTLY

If not, make both of those changes and see how that works out.

Also, when using a dedicated radio NIC with a static IP address, you must set the radio to use a static IP on the radio subnet. You will need to use HPSDR Programmer or HPSDR Bootloader to do that.


All was ok win lan settings. the problem was the Buffer size. i had buffer set at 128. SO have delay in TX panadapter visualizationa and glitches.

increasing the buffer to 1024 i have less problems.

with 1Rx open and sample rate set to 96000 i don't see differences with 1 or 2 lan used.
the real used bandwith is always less then 100mbit.

the main problem is that need have a fast pc in order to have no problems.

this is my experience with 3 different laptop and 2 small pc.
All computers have win 10 system, 8gb ram, ssd hdd. M/b and cpu was different (1 has i5 and all other i7)

I'm sure with faster machine will not have any glitches or any other delay during operation.

With my slower machine the HPSDR has always 30% of cpu usage in simpler RX state. With faster one has 20%. Again no difference if use 1 or 2 lan

if you run on same pc log and another software for CW or Digital i had seriul delay. Never had this kind of problems with same computers whiles using sunsdr or flexradio

there are just my impressions or is all normal like this?

Thanks
User avatar
w-u-2-o
Posts: 1888
Joined: Fri Mar 10, 2017 1:47 pm

Re: anan 7000 and pc issue

Postby w-u-2-o » Wed Apr 10, 2019 12:45 am

Your PC's should be able to handle 192KHz sampling rates no problem.

See this thread and try some of the tests suggested there to see if you can find any problems:

https://apache-labs.com/community/viewtopic.php?f=6&t=2952&p=6415

Return to “PC's & Homebrew Hardware”