Thetis DRIVE CONTROL IN TRANSVERTER MODE

gw3uzs
Posts: 6
Joined: Mon Apr 10, 2017 7:40 am

Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby gw3uzs » Mon Feb 15, 2021 10:12 am

I have a query regarding the software control of power output using Thetis when in transverter mode.

It appears that the control of power out in transverter mode has only 4/5 step changes in power out as you vary the drive control from 0 – 100. In the HF mode (on 10M) you have a reasonably fine control of power out as you vary the drive control from 0 - 100 .

I wonder if anyone has any thoughts on this please?

Many thanks Jeff GW3UZS
dl4zbg
Posts: 76
Joined: Sun Apr 09, 2017 5:33 pm

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby dl4zbg » Mon Feb 15, 2021 7:18 pm

Jeff,

I am not quite shure whether this is is an issue of the ANAN hardware.
I am using the 7000DLE. Increasing the PA settings in order to reduce the transverter output to 0dBm or even lower will lead to only 2 steps!!
Absolutely not useable. To avoid this I increased the output level to abt 50mW and added a fixed value attenuator. But at output levels greater than 30mW IM3 is only -28dBc. Not good enough.

73

Volker

DL4ZBG
gw3uzs
Posts: 6
Joined: Mon Apr 10, 2017 7:40 am

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby gw3uzs » Tue Feb 16, 2021 10:12 am

Hi Volker,
Thanks for your reply. As you say it could be a problem in the Apache labs Orion MKII SDR board which I am using in my home brew set up ( See GW3UZS -QRZ.com for more info). However, I suppose it could also be a software issue when set up for the Anan 7000 which my home brew set up is emulating.
I have a friend who has a Hermes SDR board (same as the Anan 100) and is using the latest Thetis software in transverter mode (but set up for Hermes/ Anan100 of course) and this problem does not arise.

I have also tried using the earlier 32 bit Thetis v2.7.0 software and this presents the same problem.

It is not a big issue for me but a smoother variable drive control as is the case for HF mode would be very helpful.

I wonder if anyone else has a comment on this.

73 Jeff GW3UZS
User avatar
FM5GB
Posts: 87
Joined: Sun Apr 09, 2017 10:03 pm

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby FM5GB » Fri Feb 19, 2021 9:20 pm

Hi Jeff

I'm using a rebuilt TRX from an Orion MK 1 board taken from an ANAN 200D (to be seen on my QRZ.com page). Before the last version of FW (1.9 for Orion) I had trouble with the transverter function. Which FW version are you running ?. Make sure you flash the latest Protocol 2 FW for your radio which is different from mine. You should be able to adjust CONTINUOUSLY the power on the XVTR TX output with the drive slider from zero to maximum. Maximum will be adjustable int Setrup/PA Settings for different transverters you operate. On 145 MHz I could output about a 13 dBm (20 mW) signal very clean and linear. Don't forget to check the Disable PA box in the XVTR Setup menu from the Thetis main GUI. On the latter menu you can also compensate the RX Gain from your transverter.
If the issue is still there it could be a FW issue.
I looked at your fine pictures on QRZ.com, congratulations for your outstandong job.

Edit : On the ANAN 200D/Orion MK1 firmware transverter operation was not fully implemented untill version Orion_NP_v1.9 pre3metis.rbf



73s Phil FM5GB
gw3uzs
Posts: 6
Joined: Mon Apr 10, 2017 7:40 am

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby gw3uzs » Sat Feb 20, 2021 12:36 pm

Hi Phil,
Thanks for your comments regarding the FW version. As far as I know the latest firmware for the Orion MKII board is v2.0b but I have tried this and unfortunately I have the same problem. However many thanks for your thoughts.

73 Jeff GW3UZS
User avatar
Tony EI7BMB
Posts: 421
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby Tony EI7BMB » Sat Feb 20, 2021 1:17 pm

Running firmware version 2 here and do not see to have this issue
gw3uzs
Posts: 6
Joined: Mon Apr 10, 2017 7:40 am

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby gw3uzs » Sun Feb 21, 2021 10:25 am

Hi Tony,
Thanks for the comment but I I wonder which Anan hardware you are using. I am using the Orion MKII sdr board?
Regards

jeff GW3UZS
User avatar
Tony EI7BMB
Posts: 421
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby Tony EI7BMB » Sun Feb 21, 2021 11:31 am

Sorry should have said its 7000DLE Mk2 so Orion Mk 2
K9RX
Posts: 324
Joined: Fri Apr 14, 2017 3:47 pm

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby K9RX » Sun Feb 21, 2021 2:49 pm

Tony,
So are you using the XVTR TX out jack and if so have you measured the Pout and its 'step size'?

I ask because I'm considering doing 23cm EME and would have a transverter of course to do that. I need to know what to expect from that Orion MKII XVTR TX output jack. [rig is 8000 but of course same HW]

thanks

Gary
K9RX
User avatar
Tony EI7BMB
Posts: 421
Joined: Sun Apr 09, 2017 2:31 pm
Location: Dublin
Contact:

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby Tony EI7BMB » Sun Feb 21, 2021 3:51 pm

Hi Gary , yes I am using Xverter out but not measured anything I'm afraid.
gw3uzs
Posts: 6
Joined: Mon Apr 10, 2017 7:40 am

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby gw3uzs » Tue Mar 23, 2021 11:15 am

Hi all,

Thank you to all that replied to my original query.

I now have the answer - it appears that steps in the power control bar widen as you increase the thumbwheel setting number in the PA setting menu. They get progressively wider above a setting of 60. Mine was set to 73 for 2M band transverter mode because I needed less than about 2.6 dBm (1.8mW) drive at 28MHz into my transverter.

Therefore, if your transverter needs to be driven at much lower level of drive than your normal settings for 28MHz when in transverter mode then I think you will experience the same problem has I have. I will be able to resolve this in course with a change to my homebrew hardware.

Many thank again.

Jeff GW3UZS
G3ZQH
Posts: 56
Joined: Mon Apr 10, 2017 5:21 pm

Re: Thetis DRIVE CONTROL IN TRANSVERTER MODE

Postby G3ZQH » Sat Mar 27, 2021 2:52 pm

Hi Jeff
Yes, I have observed exactly the same as you when setting up my transverters. Very confusing initially when I was adjusting the VHF PA gain settings. The gain value I settled on was 55.0 for my 2m and 4m transverters. I was able to make a compromise setting to have about two drive units for one increment in power output.
73 Dave G3ZQH

Return to “Transverters”