Help needed with Behringer X-Touch-One

PD3LK
Posts: 13
Joined: Mon Nov 11, 2019 8:45 pm

Help needed with Behringer X-Touch-One

Postby PD3LK » Mon Mar 30, 2020 2:55 pm

Hi, i allready mentioned this issue end of last year.

I have a problem with a MIDI controller Behringer X-Touch-One.
All buttons, knob and slider works well but...

the wheel does not want to do "VFO freq down"... the VFO freq just doesn't change.
VFO "up" does work well but the wheel works anti-clockwise.

I use the X-Touch-One standard Midi setting but all other build-in modes (Midi-Relative, HUI, MC, CChgRel) have the same problem.
This controller (incl the wheel for VFO) works perfectly with SDR-Console (!!).

I added a few pictures of the Midi Controller Setup.
Hopefully someone can help me out to get this working in Thetis. (i use 2.7 a3)
Attachments
Mapped Controls tab.png
Mapped Controls tab.png (199.53 KiB) Viewed 1200 times
Diagnostics tab.png
Diagnostics tab.png (155.15 KiB) Viewed 1200 times
Commands tab.png
Commands tab.png (156.66 KiB) Viewed 1200 times
73 PD3LK Leon
User avatar
w-u-2-o
Posts: 2269
Joined: Fri Mar 10, 2017 1:47 pm

Re: Help needed with Behringer X-Touch-One

Postby w-u-2-o » Mon Mar 30, 2020 3:15 pm

Fixing this will require changing the software. Right now I don't know if there is anyone currently working on the MIDI part of the codebase.
PD3LK
Posts: 13
Joined: Mon Nov 11, 2019 8:45 pm

Re: Help needed with Behringer X-Touch-One

Postby PD3LK » Mon Mar 30, 2020 8:52 pm

Ahh thanks for the reply Scott, i already suspected something like that.
I'm not familiar with all involved programmers and their specialities , is this maybe something that Richie can solve? Or do you know who i can approach?
73 PD3LK Leon

Return to “MIDI Controllers (PowerSDR & Thetis)”