New 7000/8000 Orion MKII Protocol 2 Firmware Topic

FIRMWARE TOPICS ONLY--non-firmware topics will be MOVED
Forum rules
Until such time as the New Protocol firmware goes into general release, all discussion will be concentrated here.
db8gk
Posts: 18
Joined: Thu Apr 02, 2020 8:05 am

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby db8gk » Fri May 15, 2020 9:30 pm

w-u-2-o wrote:
db8gk wrote:The Bootloader source can be found under "openHPSDR-Protocol1-Programmers".


Hah, apparently I just didn't dig deep enough. Thanks! Builds from source, let's see.
NN3RP
Posts: 46
Joined: Sun Feb 25, 2018 1:53 pm

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby NN3RP » Sat May 16, 2020 12:00 am

If it helps, WSJT-X needs / demands your PC to have time synchronized with time server, i.e., using Dimension 4 software or other. Otherwise you will not be heard. I've been there done that.



Rafael / NN3RP
Rafael / NN3RP
Nation's Capital USA
K1LSB
Posts: 55
Joined: Wed Feb 05, 2020 5:25 pm

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby K1LSB » Sun May 17, 2020 3:18 am

NN3RP wrote:If it helps, WSJT-X needs / demands your PC to have time synchronized with time server, i.e., using Dimension 4 software or other. Otherwise you will not be heard. I've been there done that.

Rafael / NN3RP


Rafael,

Just a heads-up, Dimension 4 software was written for Windows 95 and hasn't been maintained for 16 years.

Mark K1LSB
User avatar
w-u-2-o
Posts: 2537
Joined: Fri Mar 10, 2017 1:47 pm

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby w-u-2-o » Sun May 17, 2020 10:41 am

Gents: let's keep the thread drift to a minimum, please. If you wish to discuss options for time sync software, please do it here: viewforum.php?f=16
User avatar
w0ivj
Posts: 1
Joined: Fri May 29, 2020 9:06 pm
Location: Boulder, CO
Contact:

Protocol 2 Firmware Problems

Postby w0ivj » Tue Jun 02, 2020 4:47 am

I am running an ANAN 7000DLE MKII with PoweSDR mRX v.3.4.9(3/19/18) using Protocol 1 Orion_MKII_v2.7_K5SO_5-4.rbf. It seems to work perfectly. When I switched to Thetis v2.6.9 (1/25/20) using Protocol 2 Orion_MKII_Protocol_2v1.9.rbf, I experienced what I think is called (elevated noise floor of doom). I understand that this results from timing errors in the firmware that happens with some hardware. In an attempt to solve this, I reverted to some different versions of P2 firmware. Here is a list of Protocol 2 firmware that I tried and some of the problems:
metis_Orion_MkII_v2.7_K5SO_5-4.rbf will not connect
metis_Orion_MkII_Prorocol_2_v2.0b.rbf puresignal will not work
metis_Orion_MkII_Protocol_2_v1.9.rbf noise floor of doom
metis_Orion_MkII_Protocol_2_v2.0_pre1.rbf This file works with no raised noise floor and puresignal but has popping audio, spectrum jumps on tune, and many sequence errors.
User avatar
w-u-2-o
Posts: 2537
Joined: Fri Mar 10, 2017 1:47 pm

Re: Protocol 2 Firmware Problems

Postby w-u-2-o » Tue Jun 02, 2020 11:22 am

w0ivj wrote:I am running an ANAN 7000DLE MKII with PoweSDR mRX v.3.4.9(3/19/18) using Protocol 1 Orion_MKII_v2.7_K5SO_5-4.rbf. It seems to work perfectly. When I switched to Thetis v2.6.9 (1/25/20) using Protocol 2 Orion_MKII_Protocol_2v1.9.rbf, I experienced what I think is called (elevated noise floor of doom). I understand that this results from timing errors in the firmware that happens with some hardware.
That is correct.
In an attempt to solve this, I reverted to some different versions of P2 firmware. Here is a list of Protocol 2 firmware that I tried and some of the problems:
metis_Orion_MkII_v2.7_K5SO_5-4.rbf will not connect
That certainly won't, it's a Protocol 1 firmware build and Thetis requires Protocol 2 firmware to be loaded.
metis_Orion_MkII_Prorocol_2_v2.0b.rbf puresignal will not work
metis_Orion_MkII_Protocol_2_v1.9.rbf noise floor of doom
metis_Orion_MkII_Protocol_2_v2.0_pre1.rbf This file works with no raised noise floor and puresignal but has popping audio, spectrum jumps on tune, and many sequence errors.
You will have to go back up to the beginning of this topic (the first post) and continue to try different versions of firmware until you find one that works. Very rarely someone will find they are in the unfortunately position of owning a serial number that will not work with any available version of P2 firmware. Let's hope that's not the case here. But you have many other versions to try still.

73,

Scott
kc2rgw
Posts: 27
Joined: Mon Jun 22, 2020 5:44 pm

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby kc2rgw » Tue Oct 20, 2020 2:15 pm

Have any of you found you need to reload firmware for glitching, similar to the database reset?

I'm running 2.0.0b on a 7000 DLE mkII and started having a lot of odd glitches with the latest 2.8.7 and now 2.8.9 Thetis. I've done database resets and re-imports. The issue seems to be a firmware issue as power cycling the radio itself "fixes" the issue but only for short periods of time.

What I'm seeing.

CTUN selected at startup, I rarely use it, I've toggled it on/off/on/off, still pops up from time to time.

PTT, mutes audio and waterfall but doesn't key the relay or bring up the transmit audio.

PureSignal stops working, toggling PSA multiple times doesn't kick it back in, takes a power cycle of the radio to bring it back.

I'm wondering if anyone has had firmware get "corrupted" and need to be reloaded?

*** Update

All of the above problems were RF in the shack...

I went crazy for a week straight. I made antenna changes and had a common mode issue that wasn't big enough to hear on my audio on most bands, my TS-590SG was unaffected, but it was enough to disrupt the ethernet link for the Anan.

I'm back to 2.0.0.b and 2.8.11 right now and it's been solid and stable on 40/80/160 and prior to the last changes (a proper balanced tuner, eliminating a balun to my ladder line in the shack) I was unable to even operate 160 with the Anan. So it was all a common mode issue that wasn't as obvious as some that I've had where I would have recognized it.

If you have mystery issues losing response or connection with the radio, it could be RF in the shack. Was a very frustrating week...I thought I might have had a hardware fault.
Last edited by kc2rgw on Thu Oct 22, 2020 1:01 pm, edited 2 times in total.
User avatar
w-u-2-o
Posts: 2537
Joined: Fri Mar 10, 2017 1:47 pm

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby w-u-2-o » Tue Oct 20, 2020 3:30 pm

Anything that requires a power cycle of the hardware indicates malfunctioning firmware. your PTT and PureSignal problems are indicative of this. The CTUN issue has nothing to do with it.

The most likely explanation is that the firmware you have loaded is just barely making timing when your hardware is cool, but as it warms up it starts to fall out of timing closure. It's not becoming corrupt, the bits and bytes in the non-volatile memory are intact, but the version you have with the hardware you have is right on the edge for timing closure vs. temperature.

I'd recommend you try a different version of the P2 firmware. Go back to the first post in this topic and pick a few to download and try. You may even need to go back to 1.9 or possibly 1.8 series revisions.
kc2rgw
Posts: 27
Joined: Mon Jun 22, 2020 5:44 pm

Re: New 7000/8000 Orion MKII Protocol 2 Firmware Topic

Postby kc2rgw » Tue Oct 20, 2020 3:36 pm

w-u-2-o wrote:I'd recommend you try a different version of the P2 firmware. Go back to the first post in this topic and pick a few to download and try. You may even need to go back to 1.9 or possibly 1.8 series revisions.


OK thanks, will see if it continues as stable with the 2.8.9 now. it was reasonably stable on 2.7.0 a3 with the 2.0.0b


**** Update

It was an RF in the shack issue all along.

Return to “Protocol 2 Firmware (all radios)”