New 100D Angelia Protocol 2 Firmware Topic

Forum rules
Until such time as the New Protocol firmware goes into general release, all discussion will be concentrated here.
User avatar
w-u-2-o
Posts: 2076
Joined: Fri Mar 10, 2017 1:47 pm

New 100D Angelia Protocol 2 Firmware Topic

Postby w-u-2-o » Mon Feb 10, 2020 3:44 pm

UPDATE 12.1_pre4 10 Feb 2020

Additional bug fixes including transverter operation, PTT fixes and timing adjustments.

Metis_Angelia_Protocol_2_v12.1_pre4.rbf
(1.32 MiB) Downloaded 23 times


Previous versions (the cryptic numbers at the end represent different Gigabit Ethernet PHY timing adjustments:

Metis_Angelia_Protocol_2_v12.1_pre2_5550.rbf
(1.32 MiB) Downloaded 9 times

Metis_Angelia_Protocol_2_v12.1_pre2.rbf
(1.32 MiB) Downloaded 5 times

Metis_Angelia_Protocol_2_v12.1_pre1_5770.rbf
(1.33 MiB) Downloaded 5 times

Metis_Angelia_Protocol_2_v12.1_pre1_5670.rbf
(1.34 MiB) Downloaded 7 times

Metis_Angelia_Protocol_2_v12.1_pre1_5171.rbf
(1.33 MiB) Downloaded 3 times

Metis_Angelia_Protocol_2_v12.1_pre1_5070.rbf
(1.33 MiB) Downloaded 4 times


And even older versions here:

https://github.com/TAPR/OpenHPSDR-Firmware/tree/master/Protocol%202/Angelia%20(ANAN-100D)
wa1oxt
Posts: 44
Joined: Mon Apr 10, 2017 7:12 pm

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby wa1oxt » Fri Feb 14, 2020 7:09 am

Great, tnx working fine.

wa1oxt / / gary
VA2EY
Posts: 21
Joined: Wed Apr 24, 2019 11:57 am

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby VA2EY » Fri Feb 14, 2020 7:42 pm

Pure signal correcting, not stable. Back with the version Angelia_Protocol_2_v11.7_7-15-18.rbf
The only one that works 95% with my device and those of my friends.
No version 12 is working yet
wa1oxt
Posts: 44
Joined: Mon Apr 10, 2017 7:12 pm

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby wa1oxt » Tue Feb 18, 2020 7:32 pm

Well guy's , after several day's I also found PS not stable with latest firmware.
Went back to PC2_ver 12.1_pre2_5550.rbf. firmware this morning and now PS is stable.

wa1oxt // garyradio
gaboughton
Posts: 2
Joined: Wed Feb 19, 2020 2:27 am

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby gaboughton » Wed Feb 19, 2020 2:41 am

Hi Folks,

I am new to Anans. I acquired a 100D from the estate of a SK. I
would like to use P2 FW on it so that I can run Thetis SW. However I
am not sure whether my radio will successfully run P2 FW. I would
appreciate any guidance.

I loaded Metis_Angelia_Protocol_2_v12.1_pre4.rbf. I tried to use it
with Thetis. It worked for a short period but then Thetis lost
contact with the Anan. Subsequently Thetis would not maintain
communication with the Anan for anything but a very short period of
time.

At that point, I had to use HPSDRBootloader and a jumper to load other
FW.

Based on one of the entries above I tried
Angelia_Protocol_2_v11.7_7-15-18.rbf. It seems to be working though I
have only tried basic features.

However I found the text below at
OpenHPSDR-Firmware/Protocol 2/Angelia (ANAN-100D)/Release_notes_summary.txt
and it scares me.

"It should be noted that there is a potential concern for Angelia and
Hermes based radios (100D, 100B, 100, 10, 10E). With the Media Access
Controller (MAC) logic on the FPGA now running at Gigabit speeds this
causes the power consumption requirements of the FPGA to increase. On
these SDR cards, overheating of the "F3" positive temperature
coefficient (PTC) device which protects the 3.3V supply has been
reported, with resulting erratic operation due to current
limitations. It is not yet clear how significant this problem may
be. The development team has not, as of yet, looked into a possible
firmware based solution for this problem (e.g. creating 100BASE-T
versions of the Protocol 2 FPGA images). You may need to consider a
hardware modification to fully support Protocol 2 Gigabit operation."

MY QUESTIONS

Are there obvious indications of the current limiting issue mentioned
above?

Does running the MAC in the Angelia FPGA at a gigabit cause any
possible damage to the FPGA, some supply, or any other portion of the
Angelia?

I am not sure what is meant by the "hardware modification" mentioned
above. Has anyone done such a modification?

I guess the real question is whether it is safe for me to run P2 FW on
my 100D. If so, any recommendations on which version will be the
safest?

Best Wishes,
Andy Boughton
kc1dmm
User avatar
w-u-2-o
Posts: 2076
Joined: Fri Mar 10, 2017 1:47 pm

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby w-u-2-o » Wed Feb 19, 2020 4:46 am

gaboughton
Posts: 2
Joined: Wed Feb 19, 2020 2:27 am

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby gaboughton » Wed Feb 19, 2020 2:33 pm

Hi Scott,

Thanks so much!

My symptoms seem similar to those of Bob, ko2f. I will order a 4A fuse though it sounds like the fuse may not be my problem. As I mentioned, I found a FW version that seems to work for me but I will also try the version that works for Bob since it is newer.

Best Wishes,
Andy
kc1dmm
KD8K
Posts: 1
Joined: Fri Feb 21, 2020 11:50 pm

Re: New 100D Angelia Protocol 2 Firmware Topic

Postby KD8K » Sat Feb 22, 2020 6:33 am

This version has been working very well for me except for one issue I am noticing. When the LPF "6m/ByPass on RX" setting is selected (Under General,HPF/LPF) I get significantly more power output when transmitting on CW. For instance, on 40 meters when deselected I get around 100 watts, when selected I get over 125 Watts. This is measured using the watt meter on my KPA-500 amplifier (in bypass mode). and similar results using the watt meter on my MFJ Tuner. I have deselected and selected it multiple times and the power output increase seems to follow the check mark. Not sure why this setting has an affect on power output, but it does seem consistent with the setting. This is measured when transmitting into a dummy load.


John KD8K

Return to “Protocol 2 (all radios)”