Anan 100d with Angelia and P2

FIRMWARE TOPICS ONLY--non-firmware topics will be MOVED
Anthony_G7LRQ
Posts: 8
Joined: Wed Aug 11, 2021 8:05 pm

Anan 100d with Angelia and P2

Postby Anthony_G7LRQ » Thu Aug 19, 2021 2:19 pm

I have recently purchased an 100d which has a Angelia board fitted, it came with P1 installed and works as expected.

I have tried various version of P2 and I cannot get it work with any of them, the RX quickly jumps up and down to full signal and appears to also be losing connection. I have tried this with the latest PC software and a PiHpSDR V2 interface, it makes no difference, but works 100% with P1 installed.

Does anyone have an idea why I cant get it to run any P2 versions. Could it be faulty and only running P1?

Any help or suggestion gratefully appreciated.

Regard Anthony
User avatar
w-u-2-o
Posts: 3315
Joined: Fri Mar 10, 2017 1:47 pm

Re: Anan 100d with Angelia and P2

Postby w-u-2-o » Thu Aug 19, 2021 2:40 pm

Anthony,

Welcome to the community! It can be a steep learning curve, but this forum has lots of info. in it to help.

Your hardware is not faulty. Developing reliable, fully functional P2 firmware for all the openHPSDR hardware has proven to be very difficult because some FPGA pin assignments were not optimized for gigabit Ethernet, and because of a desire to use free design tools that don't allow floor-planning and incremental FPGA builds which, again, would make the gigabit part of the design easier to realize. Nevertheless, Rick, N1GP, has been working very diligently on it over the past year or so and has had some great success in working around these issues, with nearly 100% of the Orion MKII folks working, and perhaps 90% of the Orion units.

There has not been a lot of interest among Angelia users, but Rick also posted a new build for the Angelia just recently. It would be great if you could try it out.

You need to look at this topic:

viewtopic.php?f=32&t=3311

Not only should you try the latest build, but perhaps some of the older builds--you might get lucky! And please post your results at the bottom of that topic so they show up with everyone else's.

You also need to look at this topic:

viewtopic.php?f=17&t=2777&p=8593

The higher FPGA current consumption requires modifying your Angelia card for reliable operation.

73,

Scott

Return to “Angelia Firmware (100D)”