SoftEther VPN and Anan issues

Can't talk to your radio? This is the place to ask!
ea3aqr
Posts: 85
Joined: Mon Mar 04, 2019 10:50 pm
Location: BCN

SoftEther VPN and Anan issues

Postby ea3aqr » Tue Aug 11, 2020 11:08 am

Hello,

I'm trying to set up a new VPN with SoftEther ( https://www.softether.org/ ) for remote operation.

Currently I have one OpenVpn tunnel up and running on a second RaspberryPi that works fine for remote operation, but unfortunately some times it collapses and starts loosing a lot of packets.

After Googling for the best VPN software I ended installing SoftEther. I can establish my VPN tunnel and connect to my lan, browse my NAS and computers, control my rotator... Unfortunately I can not start comunication to my Anan 7000 DLE using Thetis. I can use my radio via SoftEther VPN If I use SDR Console instead of Thetis.

I can ping the Anan's fixed IP without any problem, but I am unable to start Thetis/Anan comunication.
After 3 days of test I can conclude that there is a problem with the first broadcast packet that Thetis sends to start comunicating with the radio.

Using WireShark we can see that instead of sending a broadcast UDP (17) packet to the LAN to start the communication with the Anan radio, when we are connected through SoftEther VPN, the packet , that is also a UDP (17), changes its destination IP address to the IP address of the computer running Thetis when it should be the address of the broadcast IP of our subnet.

We cannot understand why using SoftEther and Thetis this initial packet is changing the destination address.

Any clue?

Thanks
User avatar
w-u-2-o
Posts: 2599
Joined: Fri Mar 10, 2017 1:47 pm

Re: SoftEther VPN and Anan issues

Postby w-u-2-o » Tue Aug 11, 2020 3:13 pm

Don't have a clue. However, it may be a moot point if you don't have a WAN connection that is capable of running the data rate that a thick client SDR demands.

You might try using Resmon to see how much network bandwidth Thetis is using in your preferred configuration in order to judge whether your VPN over the internet will be able to support proper operation.
ea3aqr
Posts: 85
Joined: Mon Mar 04, 2019 10:50 pm
Location: BCN

Re: SoftEther VPN and Anan issues

Postby ea3aqr » Tue Aug 11, 2020 4:13 pm

My WAN connection (600Mbps at home and 300Mbps at the remote location) is capable of running the data rate most of the time. Thetis/Anan data stream is usually arround 10-20Mbps at 192Khz bandwith.

I've used my radio remotely this way so many times, I was just trying to improve it because I've read that OpenVPN tends to collapse sometime. From time to time I have a huge packet loss and I can see a big latency increase in my connection. Usually my latencies are arround 32ms, but some times they go to a crazy 300+ ms.

I was just trying to test if the problem was related to the internet connection or it is just an issue with my OpenVPN tunnel colapsing.

Anyway thanks for the answer.
ea3aqr
Posts: 85
Joined: Mon Mar 04, 2019 10:50 pm
Location: BCN

Re: SoftEther VPN and Anan issues

Postby ea3aqr » Fri Aug 14, 2020 8:03 am

All remote operation packet loss issues has gone by just replacing my +10 years old deprecated Intel i5-750 by a new Ryzen 5 3600 computer.

So it was not an OpenVPN related issue.

Return to “Network Connections & Network Hardware”