Page 1 of 1

Ethernet loss

Posted: Thu Nov 01, 2018 8:52 pm
by therealboss
A bit of a strange one, but there again I think any issue is strange until you have one.

Everything was working fine, Protocol 1 and PowerSDR mRX PS v3.4.9

So why play about with it you may ask, well I wanted to try Protocol 2 again as there is a later version of before.

I installed P2 firmware but had an issue that I could not access the radio so decided to go back to P1,

Problem is now, I have packet loss and other times I loose total connection to the radio.

I fire up the radio but not PowerSDR and ping the radio, radio is connected with a static IP on a dedicated network card and I run a continues ping to the radio.

Ping statistics for
Packets: Sent = 1030, Received = 1001, Lost = 29 (2% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 6ms, Average = 2ms

sometimes it just 1 or 2 pings that drop and other times it just looses connection and the only way to reconnect is to disable the network card and re enable it.

I have tested with 3 network cards and have the same issue with them all, I have tested with firmware Orion_v5.1 and Orion_v5.2 and have the same issue with both. When I load Protocol 2 firmware I can't ping the radio at all but the static IP is staying on the radio as when I change back to Protocol 1 firmware I can again ping the radio.

Looks like the network adapter has gone west after trying to load Protocol 2.

Like I said, up to today everything has been working fine and now this issue after trying to change the firmware, if I plug in another device to the network card I can ping it 100% without any packet loss.

The radio has a dedicated network card and it's not plugged in via a switch, it's a direct connection, the PC it a bit of a monster, it's a i7 running at 3.4GHz 128GB Fast RAM and 1TB SSD + 250GB SSD to run Windows 10 Pro. Network Card now in Intel Pro /1000 Dual Port but had tried both an Intel Pro and a Realtek.

Anyone got any suggestions?

Re: Ethernet loss

Posted: Fri Nov 02, 2018 12:39 am
by w-u-2-o
Loading P2 or P1 firmware cannot damage the hardware.

The implementation of a NIC on the radio hardware is exceptionally simple: the MAC is in the FPGA, the PHY is a single chip, and there is connector with integrated magnetics. That's it.

That the P2 firmware available in the TAPR Git repository did not work is not a surprise. What is currently there is not reliable on all radios. That includes ping.

Ping in P1 is not wholly reliable, however PowerSDR should run reliably.

I'd look for coincidentally bad cables or connectors.

Re: Ethernet loss

Posted: Fri Nov 02, 2018 1:06 am
by therealboss
Network cable changed but old cable checks out 100% OK with a cable tester.

I'm running a constant ping to the radio and sometimes it drops 1 ping and that's not an issue but when it drops several pings PowerSDR hangs, if the pings come back PowerSDR will start running again but if pings stop the connection to the radio is broken and the only way I can get it to run again is to power cycle the radio and then the pings start again. If it just drops a few pings there is a hesitation in PowerSDR and connection to radio is broken but if pings start again, then audio only drops out for a few seconds.

Re: Ethernet loss

Posted: Sat Nov 03, 2018 5:12 pm
by therealboss
Issue resolved, everything works fine if I DO NOT ping the radio when I want to use it, very strange.

Re: Ethernet loss

Posted: Sat Nov 03, 2018 7:52 pm
by w-u-2-o
therealboss wrote:Issue resolved, everything works fine if I DO NOT ping the radio when I want to use it, very strange.
Not strange at all given that the NIC implementation in the hardware is very primitive, but certainly unusual when compared to nearly any other piece of gear that has networking capabilities. Unfortunately this hardware has little to no margin for multi-tasking.