Anan 200D bricked

Can't talk to your radio? This is the place to ask!
G3ZQH
Posts: 29
Joined: Mon Apr 10, 2017 5:21 pm

Anan 200D bricked

Postby G3ZQH » Thu Oct 25, 2018 9:59 pm

I have the dreaded “Error starting HPSDR hardware, is it connected and powered?". In the past I have been able to sort this out using Bootloader, but not this time. I have tried all the options in this forum with little success- including W1AEX suggestions on his web pages. I normally use protocol 1 (v 4.9 Orion) with PowerSDRmrx but the rbf firmware file could not be loaded at all. I did manage to get Protocol 2 (renamed 'metis.rbf') loaded using Bootloader. However, nothing I tried would allow the 200D to be recognised. I suspect this is a network problem. However, the reason I tried to reload the firmware was that I was getting some strange effects with communication with the 200D, so maybe there is a deeper problem?

So, I have tried HPSDRProgrammer, Bootloader and the new Protocol 2 loader (via web browser) but none will recognise my 200D rig.

Grateful to receive any advice to resolve this problem. I'm no expert on network problems so it could be something very simple that I am overlooking. My rig is connected via a gigabyte Ethernet switch, which I have used for a long time with no problems.

73 Dave G3ZQH
User avatar
w-u-2-o
Posts: 1875
Joined: Fri Mar 10, 2017 1:47 pm

Re: Anan 200D bricked

Postby w-u-2-o » Fri Oct 26, 2018 2:01 am

Bootloader is the Gold Standard. At this point I would ignore ALL else.

Bootloader relies only on broadcast packets so does not care about IP addresses. If you have the radio directly connected to a NIC on the PC, and all other NICs (including Wi-Fi) disabled, barring a broken cable if you cannot make contact with the radio using bootloader then it is very likely that your radio is hard-broke and needs to go out for repair.

This does assume you have not made gross errors like using a bad cable, having the bootloader switch in the wrong position, forgetting to power cycle (reboot) the radio after moving the switch, etc.

73,

Scott
G3ZQH
Posts: 29
Joined: Mon Apr 10, 2017 5:21 pm

Re: Anan 200D bricked

Postby G3ZQH » Fri Oct 26, 2018 8:48 am

Hi Scott
The rig came back to life, but I didn't do anything specific to achieve this. It was just left overnight. Since then, it has dropped out again a few times this morning. This makes me think that there might be an intermittent problem, possibly something simple like a bad connection from the ethernet connector inside the rig. I have tried several different ethernet cables, so the problem is not due to a damaged cable. I have been using Thetis and SDRConsole v3 (to go with Protocol 2) on the 200D) both of which can communicate with the rig (at least at the moment).

Thanks for the quick response and confirmation that I was trying the right approach. I'll report back if I can track down a specific solution to the problem.

73 Dave G3ZQH
User avatar
w-u-2-o
Posts: 1875
Joined: Fri Mar 10, 2017 1:47 pm

Re: Anan 200D bricked

Postby w-u-2-o » Fri Oct 26, 2018 6:54 pm

Such intermittent behavior is not atypical of the P2 firmware currently published on the TAPR Git repository. When timing closure is marginal, an increase in radio temperature can cause it to go out of bounds.

It is suggested that it may be worth moving back to P1 firmware to at least determine whether it is the P2 firmware that is the issue, or some other problem.

Do also look at the voltage at the power connector right at the radio, and check the fuse holder for any thermal damage. If voltage is marginal at the rear panel connector that can also cause intermittent operation.

73,

Scott
G3ZQH
Posts: 29
Joined: Mon Apr 10, 2017 5:21 pm

Re: Anan 200D bricked

Postby G3ZQH » Mon Nov 12, 2018 9:48 pm

After a few weeks of checking I never did confirm the cause of my problems with loading the firmware. It is now working fine and I can load either P1 or P2 without problem. using a combination of the new programmer and the original HPSDR programmer (no need for Bootloader). My best guess was that it was due to a bad connection to the network socket on the rig. I had moved all my equipment to a new room just before I had these problems- a lot of dust and mess involved- so I suspect that some debris got stuck inside the RJ45 socket on the radio (though I never actually saw anything there...).

I've been trying Protocol 2 with Thetis and with Simon Brown's SDR Console. using my 200D. Thetis sort of works, but drops out every few days for no apparent reason. I did manage to get PureSignal working, but just for a few transmissions on SSB, then it never worked again.

SDR Console looks really nice- lots of good features. However, still not fully functional with various items like PureSignal and CESSB not yet incorporated. However, what is there currently in SDRConsole is very impressive, so this could be one to watch for the future. Unfortunately, it also crashes so is not yet stable.

So, I'm now back on P1, running PSDRmrx v 4.9, which is very stable for me on my 200D.

73 Dave G3ZQH
User avatar
w-u-2-o
Posts: 1875
Joined: Fri Mar 10, 2017 1:47 pm

Re: Anan 200D bricked

Postby w-u-2-o » Mon Nov 12, 2018 10:40 pm

:)

Return to “Network Connections & Network Hardware”