Do not use APIPA when programming an IP address!

Can't talk to your radio? This is the place to ask!
dl1ycf
Posts: 10
Joined: Fri May 17, 2019 7:16 am

Do not use APIPA when programming an IP address!

Postby dl1ycf » Fri May 17, 2019 11:58 am

Dear all,

If you "program" a new IP address into an ANAN-7000 (this probably is also true for all other devices), the netmask is tacitly kept (left unchanged). This means it is not possible to "program" an IP adress, say, 192.168.1.12 with netmask 255.255.255.0, by simply connecting an out-of-the-box ANAN with a PC through a direct ethernet cable and using the HPSDRBootloader utility.

In this case, PC and ANAN communicat using a "private" APIPA address of form 169.254.xxx.yyy with netmask 255.255.0.0, and this mask is then retained and the ANAN will not work in a DHCP-less network 192.168.1.xxx (with netmask 255.255.255.0).

This is really true, changing the mask to 255.255.0.0 in my local 192.168 net did the job.

So you see, you MUST connect PC, Anan and a DHCP server to a switch, such that both PC and ANAN get an IP address in a local net with mask 255.255.255.0, and ONLY THEN you should program the new IP address to the ANAN.

This is nowhere documented, but (as I discussed with W1AEX) explains some other "strange problems" observed in the past quite well.

Yours, Chris DL1YCF
User avatar
W1AEX
Posts: 316
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: Do not use APIPA when programming an IP address!

Postby W1AEX » Fri May 17, 2019 12:45 pm

The advice posted by Chris is excellent and it is a good explanation for why some users are unable to make a static IP assignment work with a direct connection between their computer and their ANAN. I was not aware of the "sticky" netmask assignment of 255.255.0.0 that exists when an IP is derived through APIPA but a quick check at my favorite go-to network resource (Wireshark) confirms this.

https://wiki.wireshark.org/APIPA

Obviously, if you are directly connecting to any ANAN that has an APIPA 169.x.x.x address and you have created a NIC address of 192.168.x.x for the computer's second NIC, windows will assign a default netmask of 255.255.255.0 to your computer's NIC. This will not connect to any IP address that is assigned to the ANAN with HPSDRProgrammer or Bootloader if it has a 169.x.x.x APIPA address because the netmask assigned to your ANAN through APIPA will have the 255.255.0.0 mask address. To get this working you should connect the ANAN to a router so it receives an IP through DHCP where it will receive an IP with a netmask of 255.255.255.0, and then use HPSDRProgrammer or Bootloader to make your static IP assignment to the ANAN, or change the netmask address of your computer's second NIC to match the APIPA netmask of 255.255.0.0 that is in the ANAN.

Thanks for sharing what you found Chris. I think this will help a lot of people who were unable to establish a working direct connection with a static IP assignment on a second NIC port.

73,

Rob W1AEX
"One thing I am certain of is that there is too much certainty in the world."
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Fri May 17, 2019 2:06 pm

What is described doesn't seem to be a problem. It is the normal functioning of APIPA. Since APIPA will randomly assign an IP of form 169.254.x.x using the last two octets the APIPA subnet mask MUST be 255.255.0.0 on any interface that uses APIPA, PC or radio. If it is not then there is a good chance you will be disappointed.

Similarly, one cannot have a static IP set on a PC NIC and expect APIPA to work. It needs to be set for DHCP.

Also, if the radio should have a subnet mask of 255.255.0.0 that really has no bearing on the situation even when it is using a static IP or DHCP IP. The radio will respond to more IP addresses, not less.

None of what is described changes the fact that to change the radio IP address with HPSDR Programmer the PC must have access to the radio subnet by an appropriate combination of IP address and subnet mask. Of course, none of this matters if one uses HPSDR Bootloader to change the radio's IP address, because HPSDR Bootloader uses raw Ethernet frames to do this and doesn't care about IP addresses or subnet masks, only the MAC of the radio. One oddity: in Bootloader mode the radio artificially changes its MAC to 00-11-22-33-44-55-66, which is an illegal MAC and it will not be passed by any Layer 2 or Layer 3 managed Ethernet switch.

So what am I missing? Where is the problem? It all seems to be working as expected according to the Ethernet networking standards, except for the aberrant MAC address that Bootloader uses.
User avatar
W1AEX
Posts: 316
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: Do not use APIPA when programming an IP address!

Postby W1AEX » Fri May 17, 2019 7:44 pm

The problem is that if you set the IP address of the ANAN with HPSDRProgrammer or Bootloader while the ANAN is directly connected and using the self-assigned 169.xxx.xxx.xxx APIPA address it will take whatever 192.168.x.x or 10.x.x.x IP address you program it with but it will retain the 255.255.0.0 mask used by APIPA. When configured like that It may not talk to your computer's NIC which presumably is in the same subnet as the ANAN's manually assigned IP but will have the windows assigned 255.255.255.0 mask.
"One thing I am certain of is that there is too much certainty in the world."
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Fri May 17, 2019 9:37 pm

Again, if, hypothetically speaking, if the radio has an IP of 192.168.1.5, and the PC is 192.168.1.4, then it should not matter if the radio subnet mask is 255.255.0.0. With that subnet mask the radio should happily communicate with any IP in the range of 192.168.x.x.

I just took a look through the P1 firmware code and don't see where the subnet mask is used or assigned at all.

Also, there is no way that I know of to know what the subnet mask of the radio is. Ping will not reveal this information, nor will any arp command.
User avatar
W1AEX
Posts: 316
Joined: Sun Apr 09, 2017 6:17 pm
Location: Connecticut, USA
Contact:

Re: Do not use APIPA when programming an IP address!

Postby W1AEX » Sat May 18, 2019 12:04 am

Scott,

As you said, who knows what mask assignment the ANAN actually has? Watching my ANAN subnet with Wireshark simply shows UDP packets happily going back and forth from 192.168.5.1 (the NIC) and 192.168.5.2 (the ANAN) with no cares at all. My guess is that if the ANAN and the NIC it is directly connected to are in different class subnets (B and C) the reliability of the connection may depend on what two IP assignments are chosen by the user who is setting up the static assignments.

Being curious, with the protocol 1 firmware installed in my 200D the HPSDRProgrammer would not find my 200D when the NIC mask was changed to (class B) 255.255.0.0 and didn't match the presumed (class C) 255.255.255.0 mask of the ANAN. OpenHPSDR didn't seem to care and found the ANAN right away with the mismatch. After I closed down OpenHPSDR I tried the HPSDRProgrammer again and it found the ANAN, however, it was hit or miss with several more attempts. I didn't check, but I'm sure the Bootloader would have no problem with the mask mismatch.

There have been probably a dozen people who have contacted me over the past 4 years because they could not get a static assignment to work and I am wondering now if they tried to set the IP while directly connected with the ANAN sitting there with its APIPA self configuration assignment and ran into what Cristoph did where he was unable to connect until he changed his NIC mask to match the presumed class B mask assignment given by APIPA to his ANAN.

It's cloudy enough for me to suggest that it's wiser to assign a static IP through a router!
"One thing I am certain of is that there is too much certainty in the world."
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sat May 18, 2019 12:14 pm

W1AEX wrote:There have been probably a dozen people who have contacted me over the past 4 years because they could not get a static assignment to work and I am wondering now if they tried to set the IP while directly connected with the ANAN sitting there with its APIPA self configuration assignment and ran into what Cristoph did where he was unable to connect until he changed his NIC mask to match the presumed class B mask assignment given by APIPA to his ANAN.
Again, the NIC subnet mask on the PC side should not need to change from 255.255.255.0 except when using APIPA.

I'm not in a position to try this, because I'm not going to perturb my setup, but I'm pretty sure the following will work fine:

1. Obtain a correct APIPA connection to the radio (PC NIC set for DHCP and 255.255.0.0, radio set to 0.0.0.0).
2. With a correct APIPA connection established, use HPSDR Programmer to set the radio IP to 192.168.1.5.
3. Power cycle radio.
4. Change PC NIC to a proper static IP of 192.168.1.4 and subnet mask of 255.255.255.0.

At this point you should be able to communicate with the radio.

The above example assumes no IP address conflicts on the network with 192.168.1.4 and 5 addresses. Adjust as required for the experiment.
dl1ycf
Posts: 10
Joined: Fri May 17, 2019 7:16 am

Re: Do not use APIPA when programming an IP address!

Postby dl1ycf » Mon Aug 05, 2019 10:25 am

w-u-2-o wrote:Again, if, hypothetically speaking, if the radio has an IP of 192.168.1.5, and the PC is 192.168.1.4, then it should not matter if the radio subnet mask is 255.255.0.0. With that subnet mask the radio should happily communicate with any IP in the range of 192.168.x.x.

I just took a look through the P1 firmware code and don't see where the subnet mask is used or assigned at all.

Also, there is no way that I know of to know what the subnet mask of the radio is. Ping will not reveal this information, nor will any arp command.


This is plainly wrong. The subnet mask implicitly determines the broadcast address.

DL1YCF Christoph.
dl1ycf
Posts: 10
Joined: Fri May 17, 2019 7:16 am

Re: Do not use APIPA when programming an IP address!

Postby dl1ycf » Mon Aug 05, 2019 10:31 am

W1AEX wrote:Scott,

It's cloudy enough for me to suggest that it's wiser to assign a static IP through a router!


The main reason for assigning a static IP address is (at least for me) that I can use the gear both in my lab (connected to a switch)
and for doing QSOs (where I have a direct wire between the SDR and my Laptop, no router, no switch).

Having a fixed IP address, say, 192.168.1.98, is just working fine also when connected to a DHCP router for the 192.168.1.xxx
subnet, because these routers usually assign addresses from the "low end". Sometimes I replace the switch by a router
(for doing OS updates on the Raspberry and TinkerBoard). But normally 192.168.1.x is a "local subnet" in my lab.

So my fixed-IP-ANAN just plays well, no matter whether it is connected to a router, to a switch, or directly to the PC.

DL1YCF Christoph.
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Mon Aug 05, 2019 11:22 am

dl1ycf wrote:
w-u-2-o wrote:Again, if, hypothetically speaking, if the radio has an IP of 192.168.1.5, and the PC is 192.168.1.4, then it should not matter if the radio subnet mask is 255.255.0.0. With that subnet mask the radio should happily communicate with any IP in the range of 192.168.x.x.

I just took a look through the P1 firmware code and don't see where the subnet mask is used or assigned at all.

Also, there is no way that I know of to know what the subnet mask of the radio is. Ping will not reveal this information, nor will any arp command.


This is plainly wrong. The subnet mask implicitly determines the broadcast address.

DL1YCF Christoph.
It is not wrong. And the broadcast address, which, while you are certainly correct about how it will change based on the subnet mask, has absolutely nothing to do with this issue. Any discussion of broadcast address is not relevant to this issue.
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Wed Sep 23, 2020 3:12 pm

When I got my new 7000dle I plugged it directly into my extra NIC and it came right up. Worked great for 2 months until my son, an IT guy, convinced me to use a static IP. I did so and it worked for a week or so then suddenly I am in a total mess.
Every morning when I awake the PC, the Anan won't connect and I spend 2 hours flipping switch, unhooking cables, changing NICs rebooting etc. Until suddenly it starts working for no apparent reason. The subnet mast thing just further confuses me.

Now what I want to do is get this thing back to square one where it will use DHCP and that APIPA. Once that is accomplished I'll never mess with static IP address again.

I tried reinstalling protocol 2 but my static IP remained in the Anan.

I was comforted after reading this thread and seeing how even the experts don't understand or agree. Ahhhh.
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Wed Sep 23, 2020 4:50 pm

There is a difference between understanding and agreeing ;)

Installing firmware will not change the assigned IP address, it is stored in a separate memory location in the hardware.

Your choices are static, APIPA or DHCP. You only use one mode at a time. They all work perfectly fine, although with APIPA it can sometimes take a minute or two for the PC and the ANAN hardware to find each other. That is why I don't like APIPA. That pause will often fool you into thinking it is not working. You need to wait some period of time after powering everything up before trying to use it when everything is configured for APIPA. Not sure how long that is, because I don't use APIPA. With a static IP properly set up, or a properly set up DHCP arrangement, everything is pretty much instant.

If you want to go back to APIPA you need to do two things.

1. Use Bootloader to set the IP address in the ANAN hardware to 0.0.0.0.

2. Set the extra NIC on the PC to DHCP mode (and, yes, that is confusing as HELL, shouldn't there be an APIPA setting, right? But NO, that's not how it works :roll: )

To set the extra NIC on the PC to DHCP, on your PC, go to Control Panel (not "Settings") > Network and Sharing Center > Change Adapter Settings. Right click the adapter in question and select Properties. Select Internet Protocol Version 4 and click Properties. Select Obtain IP address automatically and Obtain DNS server address automatically. Click OK a bunch of times to close all the windows.

With those settings in place, when you power up the PC, or power up the ANAN, the network adapter will look for a DHCP server. After some number of seconds/minutes, if it doesn't get a DHCP address, it will make up it's own APIPA address in the range of 169.254.0.0 – 169.254.255.255. APIPA checks the network so that it doesn't create a duplicate address, so you don't have to worry about that.
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Fri Oct 02, 2020 5:00 pm

Thanks to the above suggestion I (THINK) I got it working again with DHCP however I continue to fight it every morning upon waking the PC from sleep mode. So far I haven't pinned down what's causing this.
I even got a new PC yesterday. Everything worked great until this morning and it took me 4 hours to get it running again.
I even went back to protocol 1 and PowerSDR but it still wouldn't connect. Then I went back to P2/thetis again and suddenly it started working.
I've been swapping between 3 computers, multiple cables, power off/on. Just an unending stream of trial and error.

Basically the software just can't connect at 1GB. Bootloader at 100mb does fine. Then for some unknown it works. Wish I knew why. I was about to give up and send it off for repair.

Here's one mystery for me. Why doesn't the ANAN address show 0.0.0.0 like It does when I query it in bootloader. No matter what, it says at 169.254.156.54. even through all these reinstalls. No matter what it's stuck there.

When I look at IPCONFIG from the command line I see the computer has 169.254.221.71 with subnet mask of 255.255.0.0
Shouldn't the sub addresses match? How does 221 and 156 communicate? Yet it is working now.

I can put the computer into sleep mode then wake it up a few minutes later and all is well BUT if I let it sleep overnight I have to go through this mess again.


I tried to put the image here but don't know how. It's just the setup menu showing the ANAN Address as IP: 169.254.156.54 Ver 2.0
Should I flush it out somehow? How? Why is it even working?

I will never put this in sleep mode again. I'm not sure what is the safest way to put it to bed at night :D
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Fri Oct 02, 2020 6:44 pm

PowerSDR and Protocol 1 work ONLY at 100Mbit/s.

Bootloader works ONLY at 100MBit/s.

Thetis and Protocol 2 work ONLY at 1Gbit/s.

If you expect any other behavior you will be disappointed.

Randomly swapping between computers, cables and power cycles is not the way to fix things. You might as well just buy a voodoo doll off of eBay.

I'm just going to concentrate on Thetis/Protocol 2 for the rest of this discussion, but it is similar for PowerSDR.

When you go into Thetis > Setup > General > H/W Select and look in the lower right hand corner of the window, you will see the currently assigned IP address of the ANAN hardware. If you have set address using Bootloader to 0.0.0.0 then the address shown in the window will be either a) the APIPA address that the ANAN hardware has self-assigned OR b) the address assigned by a DHCP server. You will never see 0.0.0.0. That all zeros address is just a cheap software trick to tell the ANAN to use either APIPA or DHCP. The fact that you are seeing 169.254.156.54 means that the ANAN is successfully self-assigning an APIPA address, which is what you said you wanted to happen.

APIPA addressing uses a subnet mask of 255.255.0.0, therefore the content of the last two octants can be different and systems on an APIPA defined network can still communicate. If this still confuses you, start Google searches on "subnet mask" and "APIPA", there are plenty of good tutorials out there to read that need not be repeated here.

To me this all sounds like a PC NIC that is not waking after the computer sleeps, or hibernates, for a long time. What happens if you restart the PC?
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Fri Oct 02, 2020 8:45 pm

Ok on the last 2 digit comment. I'm learning.
The IP address shown in Thetis's menu has been the same throughout this entire debacle.

So here's a question:
When using bootloader... You ask it to show the IP address of the Anan. It comes back with 0.0.0.0 which is what I told it to do (DHCP)... So
if that is really the Anan's IP address, why then does Thetis show the 169.254 xxxx address? It's working now but when I let bootloader
find the IP I get the zeros. Is this some kind of bug? Why doesn't bootloader show the actual address?

Yes I agree that while the NIC is asleep bad things are happening but it happens with 3 different PCs which have different NICs. I leave the Anan turned on all night but put the PC to sleep. Maybe I'm the only one doing this? Is the sleeping computer sucking the Anan's brains out while asleep? There doesn't seem to be any one obvious action I can take to wake things back up.

I knew that bootloader only did 100mbs but I though pwrsdr did too. Wonder why it didn't work at 1GB?..Then when I went back to P2 and Thetis suddenly, BLAM, it works after 4 hours of battle.
I can't seem to narrow down the problem but it seem that the Anan doesn't like being "un-NIC-ed" for long periods.

Sorry to be such a pain. Normally I would just get rid of something this troublesome but I love how Thetis works, especially on CW.
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Fri Oct 02, 2020 9:21 pm

BTW: I had been using this since April with the stock DHCP settings and never had one bit of trouble UNTIL
My son, who is an "IT Expert" came down and preached to me the importance of a static IP address. I saw no need for it but I let him set it up.
It's not worked right since.
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sat Oct 03, 2020 2:08 am

n4lq wrote:So here's a question:
When using bootloader... You ask it to show the IP address of the Anan. It comes back with 0.0.0.0 which is what I told it to do (DHCP)... So
if that is really the Anan's IP address, why then does Thetis show the 169.254 xxxx address? It's working now but when I let bootloader
find the IP I get the zeros. Is this some kind of bug? Why doesn't bootloader show the actual address?

0.0.0.0 is not, and never is, the IP address of the ANAN. By commanding it to 0.0.0.0 with the Bootloader you are telling it to be a chameleon, either an APIPA based chameleon, or a DHCP based chameleon, depending on whether it detects it is in an APIPA or DHCP environment. When it detects which environment it is in it then sets its address accordingly, and that is the address you see when PowerSDR or Thetis makes contact with it.

Also, when using Bootloader TCP/IP is never in effect, no IP address is actually used. Bootloader works at the raw Ethernet frame level, without using any IP addresses.

Do your NIC settings for the NIC you are using to communicate with the ANAN look like this (don't worry about the greyed out default gateway address)?

Capture.JPG
Capture.JPG (62.05 KiB) Viewed 918 times


Is the NIC connected only to the ANAN?

What happens when you restart the computer instead of just waking it from a sleep?
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sat Oct 03, 2020 4:53 am

Yes the connection from the Anan is via cat6 about 20' long to the extra NIC in the PC.
Restarting? Well I would have to wake it up before restarting it but that doesn't help any.

I can power off/on the Anan, unplug the ethernet cable, reboot pc...nothing seems to matter. I then
go into Bootloader and try to read the IP address but as you explained, it's not really seeing the Anan's address. I guess
the 0.0.0.0. it gets back means nothing.

I end up reinstalling P2 or swapping computers...It goes on for hours... The Anan just doesn't seem to recognize the address and
kick into 1GB mode and boot up. But it eventually does.

I would love for someone to try this as an experiment. Just leave the Anan powered on with DC but turn off power in Thetis, put the pc in seep mode then see what happens in the morning.
What is the Anan doing when it's powered up and not connected? Is it making attempts to obtain an IP connection and finally locking up?
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sat Oct 03, 2020 10:40 am

You did not answer my question about NIC settings.
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sat Oct 03, 2020 12:35 pm

Sorry...Yes it looks exactly like your photo.
I did mention that for a while I had a static IP on this. That's what started the whole thing and you explained how to
reset the Anan back to DHCP which I did.
NETWORK.PNG
NETWORK.PNG (16.79 KiB) Viewed 891 times
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sat Oct 03, 2020 1:22 pm

Change your automatic Network Metric settings in accordance with this discussion:

http://www.w1aex.com/anan/anan.html#metric
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sat Oct 03, 2020 5:51 pm

Yes I've had that done for a long time. Doesn't seem relevant to the sleep issue though.
I'm still hoping someone will try to duplicate this problem.
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
K1LSB
Posts: 55
Joined: Wed Feb 05, 2020 5:25 pm

Re: Do not use APIPA when programming an IP address!

Postby K1LSB » Sun Oct 04, 2020 12:44 pm

n4lq wrote:I would love for someone to try this as an experiment. Just leave the Anan powered on with DC but turn off power in Thetis, put the pc in seep mode then see what happens in the morning.
What is the Anan doing when it's powered up and not connected? Is it making attempts to obtain an IP connection and finally locking up?

Stephen,

My computer and the Anan are both set to static IP addresses. They are connected directly to each other by a cat 7 cable, no ethernet switch involved (I have a separate Wi-Fi connection to the world wide web).

My habit is to leave the Anan (7KDLEMKII) powered up 24/7 unless there's a risk of thunderstorms. Whenever I leave the shack I either put the computer to sleep or power it off, such that when I return to the shack the Anan is running and the computer is either off or asleep. In any case, after I turn on the computer and open a session of Thetis it is up and running within one second or so. I've never had any problem connecting the Anan with the computer regardless of the initial state of either machine.

Here is my computer's address settings:

Capture-5.PNG
Capture-5.PNG (102.83 KiB) Viewed 821 times

Here is the Thetis Setup page prior to pushing the Thetis Radio On button:

Capture-6.PNG
Capture-6.PNG (146.24 KiB) Viewed 821 times

And here is the Thetis Setup page after pushing the Thetis Radio On button:

Capture-7.PNG
Capture-7.PNG (150.89 KiB) Viewed 821 times

Hope that helps,

Mark
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sun Oct 04, 2020 1:20 pm

OK, let's summarize:

- You say it used to work reliably with APIPA/direct connection.
- You son changed things to static IP and everything went to hell.
- We are going to assume that you did everything correctly to change it back to APIPA and it still doesn't work.

Simplest answers:

- You didn't change it back correctly.

or

- Something else must have changed that we haven't found.

It is easy to be suspicious of the second answer because you have described an incredible amount of thrashing between PC's, settings, firmware, cables, power cycles, and everything else. I do not believe it has anything to do with sleep/hibernate because you say a restart does not fix the problem.

My recommendations at this point:

1. Go back to PowerSDR and Protocol 1 until you get things rock solid reliable. We know we can trust PSDR/P1 whereas P2 can be flaky. Do this before anything else.

2. In the spirit of "insanity is always doing the same thing and expecting different results", I hate to say it, but I'd say switch back to static IP addressing.

Use Bootloader to assign a static IP address to the ANAN. Do NOT use the same subnet as used by your WiFi or any other NIC on your PC. For example, if your WiFi or other NIC is 192.168.1.x, use 192.168.5.10 on the ANAN.

In the Windows control panel set your ANAN-related NIC to (again, for example) 192.168.5.100, subnet mask 255.255.255.0, and you've already apparently got a good understanding of the Network Metric setting.

Cycle power on everything.

In PowerSDR you can just check off "Reuse Last IP Address". There is no need to explicitly specify an address in PowerSDR unless you have multiple ANAN units on the network.
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sun Oct 04, 2020 1:25 pm

Thanks for the info... Do you know what these windows are for? If you select one, what happens and how do the number get there in the first place? Did you enter your static IP manually in the top one or did the software pick it up? If you click on one then click Select IP does that put that IP address into the Anan? If so then does this take the place of bootloader?
IP windows.PNG
IP windows.PNG (37.35 KiB) Viewed 813 times
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sun Oct 04, 2020 2:28 pm

n4lq wrote:Thanks for the info... Do you know what these windows are for?
They are for people who have more than one ANAN on their network, each with a separate static IP address.
If you select one, what happens and how do the number get there in the first place?
You manually enter the number. If you select one, and check the "Enable Static IP Address" option, PowerSDR (or Thetis) will only try to connect to that address and not automatically discover the ANAN.
Did you enter your static IP manually in the top one or did the software pick it up?
Manually.
If you click on one then click Select IP does that put that IP address into the Anan?
NO. This is a very common misconception.
If so then does this take the place of bootloader?IP windows.PNG
NO.

You do not need to use these features if you have only a single ANAN unit powered up at a time on your network. If you have static IPs setup then just click "Reuse Last IP Address" to speed up discovery. And you don't even need to click that option if you don't choose to, it will work just fine without it.
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sat Oct 17, 2020 3:26 pm

I'm back with the same problem. I've been working on this for 3 hours this morning and cannot get Thetis to run.

Here's what happened:

A week ago I got a new PC, installed P2 and Thetis, upgraded to 64 bit Thetis. I'm using a second NIC with DHCP.
It has worked perfectly for the past few days.

Last night I decided to try putting the PC in SLEEP Mode for the first time. This is what caused problems before with the old PC.
I left the 7000dle mkII running.

This morning I awoke the PC, clicked POWER on Thetis and got the dreaded Error startind SDR hardware, is it connected and powered?

I had not changed a single thing and I get this!
Everything is new.... Even the CAT8 cable

Putting the PC to sleep over night causes devastating problem.

So I started try things.

Bootloader always works ok.

Rebooted everything... fail
Reinstalled PC2.....fail
Reinstalled Thetis....fail
Installed PC1 and tried running with PSDR.....fail
Tried Thetis with PC1....fail
Tried another computer...fail
Tried all the above with the other computer....fail
Tried a static IP....fail
Went back to DCHP with the 0.0.0.0 routine....fail

Bootloader always works great but no version of Thetis or Powersdr will run.

All of this and all I did was put the PC into sleep mode overnight.

I think it's something to do with with the IP address but I've tried both DHCP and Static. Yes I have the same subnet.... ALso tried 255.255.0.0 and 255.255.255.0.... No difference.

I'm out of things to try here.

Last time this happened, I kept trying things until it finally decided to work and I swore I would never put the PC to sleep again but I just
had to try it with this new PC.

Any suggestions? Is there some way to flush out this Anan and start from square one?
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
w-u-2-o
Posts: 2528
Joined: Fri Mar 10, 2017 1:47 pm

Re: Do not use APIPA when programming an IP address!

Postby w-u-2-o » Sat Oct 17, 2020 4:06 pm

It does not appear you followed my recommendations above. I'll repeat them below. Get it all rock solid on static addressing and Protocol 1. This would include your desire to put your PC to sleep. Then and only then proceed to Protocol 2. We need to know one way or the other that things either are or aren't rock solid reliable with Protocol 1 first.

w-u-2-o wrote:
1. Go back to PowerSDR and Protocol 1 until you get things rock solid reliable. We know we can trust PSDR/P1 whereas P2 can be flaky. Do this before anything else.

2. In the spirit of "insanity is always doing the same thing and expecting different results", I hate to say it, but I'd say switch back to static IP addressing.

Use Bootloader to assign a static IP address to the ANAN. Do NOT use the same subnet as used by your WiFi or any other NIC on your PC. For example, if your WiFi or other NIC is 192.168.1.x, use 192.168.5.10 on the ANAN.

In the Windows control panel set your ANAN-related NIC to (again, for example) 192.168.5.100, subnet mask 255.255.255.0, and you've already apparently got a good understanding of the Network Metric setting.

Cycle power on everything.

In PowerSDR you can just check off "Reuse Last IP Address". There is no need to explicitly specify an address in PowerSDR unless you have multiple ANAN units on the network.
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sat Oct 17, 2020 4:44 pm

I did follow your directions..... I did try Protocol 1 and it will not work either.
I'm not sure what you mean by "do not use APIPA when programming an IP address". I thought APIPA was for when you don't want to program an IP address and it would automatically assign an IP. After all, isn't that how the Anan is shipped from the factory?

So again...I did load protocol 1 or at least I think I did. These files are almost impossible to find on github. It's a very cryptic website.
I did assign an IP address with a subnet that doesn't match my other connection although I do have separate NIC cards for this.

Any idea why putting the PC to sleep would cause this? I can't believe I'm the only one. It happens with any PC I've tried.
Does the Anan keep trying to communicate with a sleeping PC and go into some kind of weird state?

I'll try PC1 again and see what happens.
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'
User avatar
n4lq
Posts: 24
Joined: Thu Apr 02, 2020 1:36 am
Location: Shelby NC

Re: Do not use APIPA when programming an IP address!

Postby n4lq » Sat Oct 17, 2020 8:36 pm

Back up and running now. Using static IP.
Still don't know what happens when the PC is in sleep mode and the Anan is turned on. Bad things for sure.
Anan 7000dle MKII, custom- i9-9900k 16gb, Asus X390-A, GeForce RTX 2060, Cat8, KPA-500 amp, EFHW antenna@80'

Return to “Network Connections & Network Hardware”