JTDX rc152 PTT not working

Taiga
Posts: 13
Joined: Fri May 22, 2020 5:11 am

JTDX rc152 PTT not working

Postby Taiga » Sat Aug 29, 2020 8:37 pm

Hi,
Recently did a clean install of JTDX rc152 as recommended on the JTDX website. Using Thetis 2.70a3 and virtual serial port emulator.

In JTDX under setup -> radio, the 'Test CAT' function turns green when pressed but the "PTT" function won't and returns an error "Hamlib error: Command rejected by the rig while setting current VFO mode"

JTDX rc 151 and earlier versions are working without issues using VSE and Thetis 2.70a3.

Am told JTDX 152 is working well w/ FLEX Smart SDR 3.

Has anyone else encountered this? Trying to determine if this is being produced by an unrecoverable bug in the new release of JTDX, or if it could be solved by changing settings in JTDX or Thetis.

Thx.
w9mdb
Posts: 188
Joined: Sun Apr 09, 2017 5:53 pm

Re: JTDX rc152 PTT not working

Postby w9mdb » Sun Aug 30, 2020 4:00 am

I just tested JTDX RC152 with my Thetis V2.7.0a3 and it works fine.
You do have "PTT Method" in JTDX rig settings as "CAT", correct?

Mike W9MDB
Taiga
Posts: 13
Joined: Fri May 22, 2020 5:11 am

Re: JTDX rc152 PTT not working

Postby Taiga » Sun Aug 30, 2020 6:28 am

Hi Mike,
Thanks so much for your kind help. Checked and JTDX is set to CAT for the PTT method. If it's working on your machine, then have probably got some configuration issue going on. Will report back if when I get it working.

73,
JS
w9mdb
Posts: 188
Joined: Sun Apr 09, 2017 5:53 pm

Re: JTDX rc152 PTT not working

Postby w9mdb » Sun Aug 30, 2020 1:00 pm

I assume you are using the TS-2000 entry?
Give this a try
Shut down JTDX

Open a cmd prompt
cd \JTDX64\152\bin
rigctl-jtdx -m 2014 -r com1 -s 115200 (adjust COM port and baud rate to suit)
T 1
T 0

That should turn transmit on and off
If that doesn't work add some debug switchs and post the last few dozen lines of the debug info that should show an error
rigctl-jtdx -m 2014 -r com1 -s 115200 -Z -vvvvv

Mike W9MDB
Taiga
Posts: 13
Joined: Fri May 22, 2020 5:11 am

Re: JTDX rc152 PTT not working

Postby Taiga » Tue Sep 01, 2020 6:07 am

Hi Mike,
Thanks again for your help. Am using the TS-2000 entry. When I try controlling the rig directly using rig-ctrl.jdx as you described above, it works properly. Some further tests :

1. Did a clean install of JTDX rc152.

2. Set up a new unique rig name for this test.

3. Under "settings -> radio tab, entered TS-2000, appropriate com port for Cat control / PTT

4. Press "Test Cat" -> turns green, Press "PTT" -> works properly

5. Hit 'OK' to close the settings dialog box.

6. Immediately re-opened the "settings dialog box -> radio tab, Press "Test Cat" -> turns green, Press "PTT" -> get the Ham lib error, doesn't work now.

For some reason it works the first time but never after that.

All the best,
JS

P.S. Thought I posted this last night around midnight, but didn't show up on the forum.
w9mdb
Posts: 188
Joined: Sun Apr 09, 2017 5:53 pm

Re: JTDX rc152 PTT not working

Postby w9mdb » Tue Sep 01, 2020 12:19 pm

I tested the same thing here and it still works.

Next step is to run this (note the "d" on rigctl).

rigctld-jtdx -m 2014 -r com1 -s 115200 -Z -vvvvv

And change JTDX to use "Hamlib Net rigctl" for the rig.

What do your rig settings look like?

Capture.PNG
Capture.PNG (24.5 KiB) Viewed 1421 times
Taiga
Posts: 13
Joined: Fri May 22, 2020 5:11 am

Re: JTDX rc152 PTT not working

Postby Taiga » Thu Sep 03, 2020 4:03 am

Hi Mike,
It works fine using the method you described! My settings are the same as you've got listed except for:

- different com port
- serial data set a 8 bits, one stop bit
- mode is set to data / packet.

Tested it again putting all the settings exactly the same as you've got above w/ the exception of the com port- same behavior; PTT doesn't work.

73,
JS
Taiga
Posts: 13
Joined: Fri May 22, 2020 5:11 am

Re: JTDX rc152 PTT not working

Postby Taiga » Fri Sep 04, 2020 4:07 am

Hi Mike,
I tried setting Thetis setup -> CAT -> "ID as" from TS-2000 to PowerSDR, and selected FlexRadio PowerSDR in JTDX rc152's radio setup; and PTT now works properly (as far as I can tell).

Are there any adverse effects you know of using "PowerSDR" instead of the TS-2000 for CAT control?

Thanks for all of your help,

73,
JS

Return to “Digital Mode, Rig Control & Logging Software”